Hdu 5547 Sudoku(枚举)

Problem Description
Yi Sima was one of the best counselors of Cao Cao. He likes to play a funny game himself. It looks like the modern Sudoku, but smaller.

Actually, Yi Sima was playing it different. First of all, he tried to generate a 4×4 board with every row contains 1 to 4, every column contains 1 to 4. Also he made sure that if we cut the board into four 2×2 pieces, every piece contains 1 to 4.

Then, he removed several numbers from the board and gave it to another guy to recover it. As other counselors are not as smart as Yi Sima, Yi Sima always made sure that the board only has one way to recover.

Actually, you are seeing this because you’ve passed through to the Three-Kingdom Age. You can recover the board to make Yi Sima happy and be promoted. Go and do it!!!

Input
The first line of the input gives the number of test cases, T(1≤T≤100). T test cases follow. Each test case starts with an empty line followed by 4 lines. Each line consist of 4 characters. Each character represents the number in the corresponding cell (one of ‘1’, ‘2’, ‘3’, ‘4’). ‘*’ represents that number was removed by Yi Sima.

It’s guaranteed that there will be exactly one way to recover the board.

Output
For each test case, output one line containing Case #x:, where x is the test case number (starting from 1). Then output 4 lines with 4 characters each. indicate the recovered board.

Sample Input
3


2341
4123
3214
*243
312
421
134
41
*3
2
41
4
2

Sample Output
Case #1:
1432
2341
4123
3214
Case #2:
1243
4312
3421
2134
Case #3:
3412
1234
2341
4123

题意:给你一个4*4的图形。
每个格子填上1,2,3,4
要求同行同列同区域没有重复数字。
给定一个矩形,有些格子没填,用’ * '替代。
只有唯一填充方案,让你填好这个矩形。

解题思路:由于这题的4*4的;比较小暴力枚举即可!

代码如下:

#include<stdio.h>
char n[4][4];
void fun(int i,int j);
int main()
{
    int T;
    int count = 1;
    scanf("%d",&T);
    while(T--)
    {
        int i,j;
        for(i = 0 ; i < 4 ; i++)
        {
            scanf("%s",n[i]);
            for(j = 0 ; j < 4 ; j++)
            {
                if(n[i][j] == '*')
                    n[i][j] = 0;
                else
                    n[i][j] -= 48;
            }
        }
        int k;
        for(k = 0 ; k < 20 ; k++)               //套次循坏的目的看fun函数部分
        {
            for(i = 0 ; i < 4 ; i++)
            {
                for(j = 0 ; j < 4 ; j++)
                {
                    if(n[i][j] == 0)
                        fun(i,j);
                }
            }
        }
        printf("Case #%d:\n",count++);
        for(i = 0 ; i < 4 ; i++)
        {
            for(j = 0 ; j < 4 ; j++)
                printf("%d",n[i][j]);
            printf("\n");
        }
    }
    return 0;
}

void fun(int i,int j)
{
    int t;
    int flag = 0;                   //可填的数字个数
    int x;
    for(x = 1 ; x <= 4 ; x++)
    {
        if(x == n[i][0]|| x == n[i][1] || x == n[i][2] || x == n[i][3])             //列
            continue;
        else if(x == n[0][j] || x == n[1][j] || x == n[2][j] || x == n[3][j])       //竖
            continue;
        else if(i <= 1 && j <= 1)                                                   //左上角2*2
        {
            if(x == n[0][0] || x == n[1][0] || x == n[0][1] || x == n[1][1])
                continue;
        }
        else if(i <= 1 && j >= 2)                                                   //右上角2*2
        {
            if(x == n[0][2] || x == n[0][3] || x == n[1][2] || x == n[1][3])
                continue;
        }
        else if(i >= 2 && j <= 1)                                                   //左下角2*2
        {
            if(x == n[2][0] || x == n[2][1] || x == n[3][0] || x == n[3][1])
                continue;
        }
        else                                                                        //右下角2*2(有的老铁可能会问,那中间2*2不用判断吗?真不用,行列确定,周围确定,那么中间也是确定的)
        {
            if(x == n[2][2] || x == n[2][3] || x == n[3][2] || x == n[3][3])
                continue;
        }
        t = x;
        flag++;             //表示该点可以填x
    }
    if(flag == 1)           //当该点只能填一个数时,才将其填入,因为上面主函数在找0时,外层还需要一层循坏
        n[i][j] = t;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值