POJ3259(栈)
Bad Hair Day
Description
Some of Farmer John’s N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows’ heads.
Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.
Consider this example:
=
= =
= - = Cows facing right -->
= = =
= - = = =
= = = = = =
1 2 3 4 5 6
Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow’s hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow’s hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!
Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.
Input
Line 1: The number of cows, N.
Lines 2…N+1: Line i+1 contains a single integer that is the height of cow i.
Output
Line 1: A single integer that is the sum of c1 through cN.
Sample Input
6
10
3
7
4
12
2
Sample Output
5
题意
一群牛排成一列,每头牛都往下看,只要他比下面的牛高,就能看到那头牛的头发
问所有的牛一共能看到多少头牛的头发
思路
用栈模拟,只要当前牛的高度大于栈顶的牛的高度,就pop,否者push
这个时候栈里的高度是单调递减的,result = result + stack.size();就行了
代码
package _stack.problem3250;
import java.util.Scanner;
import java.util.Stack;
public class BadHairDay {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
Stack<Long> stack = new Stack<Long>();
int n = sc.nextInt();
Long result = 0l;
for (int i = 0; i < n; i++) {
Long tmp = sc.nextLong();
while (!stack.isEmpty() && tmp >= stack.peek()) {
stack.pop();
}
result = result + stack.size();
stack.push(tmp);
}
System.out.println(result);
}
}