POJ 1250 Tanning Salon

Description

Tan Your Hide, Inc., owns several coin-operated tanning salons. Research has shown that if a customer arrives and there are no beds available, the customer will turn around and leave, thus costing the company a sale. Your task is to write a program that tells the company how many customers left without tanning.

Input

The input consists of data for one or more salons, followed by a line containing the number 0 that signals the end of the input. Data for each salon is a single line containing a positive integer, representing the number of tanning beds in the salon, followed by a space, followed by a sequence of uppercase letters. Letters in the sequence occur in pairs. The first occurrence indicates the arrival of a customer, the second indicates the departure of that same customer. No letter will occur in more than one pair. Customers who leave without tanning always depart before customers who are currently tanning. There are at most 20 beds per salon.

Output

For each salon, output a sentence telling how many customers, if any, walked away. Use the exact format shown below.

Sample Input

2 ABBAJJKZKZ
3 GACCBDDBAGEE
3 GACCBGDDBAEE
1 ABCBCA
0

Sample Output

All customers tanned successfully.
1 customer(s) walked away.
All customers tanned successfully.
2 customer(s) walked away.


/**
 题目:Tanning Salon
 题目链接:http://poj.org/problem?id=1250
*/

#include <iostream>
#include <string>
using namespace std;

int main()
{
	bool visited[26];
	bool tan[26];
	int bed, leave;
	string customer;
	while(cin >>bed && bed != 0) {
		cin >> customer;
		memset(visited, 0, sizeof(visited));
		memset(tan, 0, sizeof(tan));
		leave = 0;

		for(int i = 0; i < customer.length(); i++) {
			if(!visited[customer[i] - 'A']) {
				visited[customer[i] - 'A'] = true;
				if(bed > 0) {
					bed--;
					tan[customer[i] - 'A'] = true;
				} else {
					leave++;
				}
			} else {
				if(tan[customer[i] - 'A']) {
					tan[customer[i] - 'A'] = false;
					bed++;
				}
			}
		}
		if(leave == 0) 
			cout << "All customers tanned successfully." << endl;
		else {
			cout << leave;	
			cout << " customer(s) walked away." << endl;
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值