一、I - 辗转相除法求最大公约数 HDU - 1019

I - 辗转相除法求最大公约数

HDU - 1019

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
 

Input

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input

2
3 5 7 15
6 4 10296 936 1287 792 1

Sample Output

105
10296

通过求最大公约数来求最小公倍数,对于第n个数来说,如果前n-1个数的最大公约数为w

1.如果w恰好也为这个数的倍数,则计算下一个数

2.如果w不是这个数的倍数,则要求w和第n个数的最小公倍数,更新数列的最小公倍数。

#include <stdio.h>
#include <stdlib.h>

long long yueshu(long long a,long long b)
{
    if(b==0) return a;
    else return yueshu(b,a%b);
}
int main()
{
    int m,n,i,j;
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        scanf("%d",&m);
        long long  a[1000],temp,beishu;
        scanf("%I64d",&a[0]);
        beishu=a[0];
        for(j=1;j<m;j++)
        {
            scanf("%I64d",&a[j]);
            if(beishu%a[j]==0 ) continue;
            else
            {
            	if(beishu<a[j]) temp=yueshu(a[j],beishu);
                else temp=yueshu(beishu,a[j]);
                beishu=beishu*a[j]/temp;
            }
        }
        printf("%I64d\n",beishu);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值