寒假训练(五) problem I (欧几里得算法)

Time limit 1000 ms
Memory limit 32768 kB
OS Windows
Source HDU 2007-1 Programming Contest

Problem Description:
要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。

Input
数据的第一行是一个T,表示有T组数据。
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。

Output
对应每组数据输出(A/B)%9973。

Sample Input
2
1000 53
87 123456789

Sample Output
7922
6060

问题链接:https://vjudge.net/contest/279621#problem/Iu
程序说明:递归运用
AC通过的代码(借鉴某程序大佬):

#include < iostream>
using namespace std;
void fac(int a, int b, int &x, int &y);
int main()
{
	int t;
	cin >> t;
	while (t--)
	{
		int n, B;
		cin >> n >> B;
		int x, y;
		fac(B, 9973, x, y);
		if (x < 0)
			x += 9973;
		int f = x;
		int result = (n % 9973)*(f % 9973) % 9973;
		cout << result << endl;
	}
	return 0;
}

void fac(int a, int b, int &x, int &y)
{
	if (b == 0)
	{
		x = 1;
		y = 0;
		return;
	}
	int x1, y1;
	fac(b, a%b, x1, y1);
	x = y1;
	y = x1 - (a / b)*y1;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值