POJ 1852 Ants


Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 13585 Accepted: 5947

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. 

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

Source



题目的含义:
n只蚂蚁以每秒1cm的速度在长度为L cm的直杆上爬行。当有蚂蚁爬到杆子的端点就会掉落。
当有两只蚂蚁相遇,掉头后反向爬回去。对于每只蚂蚁,我们只知道它距离杆子左端的距离
xi 却不知道朝向。请输出蚂蚁全部掉下的最短与最长时间。

思路:
首先对于最短时间,看起来所有蚂蚁都朝向较近的端点走会比较好。
事实上,这种情况下不会发生两只蚂蚁相遇的情况,而且也不可能在比此
更短的时间内走到竿子的端点。当两只蚂蚁相遇后,可以认为交错后按照原来各自的方向走。
具体参见书籍《挑战程序设计竞赛(第 2 版)》P20.


输入
t 行测试数据
L
n
x1 ....xn-1



代码如下:
#include<stdio.h>
#define MAX 100000

int min(int x,int y) {
	return x<y? x:y;
}

int max(int x,int y) {
	return x>y? x:y;
}

int main() {
	int L,n,t;
	int wqs[MAX];
	int mint,maxt;
	scanf("%d",&t);
	while(t--) {
		mint=maxt=0;
		scanf("%d%d",&L,&n);
		for(int j=0; j<n; j++) {
			scanf("%d",&wqs[j]);
		}
		for(int i=0; i<n; i++) {
			mint=max(mint,min(wqs[i],L-wqs[i]));
		}
		for(int i=0; i<n; i++) {
			maxt=max(maxt,max(wqs[i],L-wqs[i]));
		}
		printf("%d %d\n",mint,maxt);
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值