HDOJ 1061 RightmostDigit (求解 a^n的后 m 位,快速幂)

RightmostDigit(Go)

Time Limit: 2000/1000 MS(Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 47569    Accepted Submission(s): 17972

Problem Description

Given apositive integer N, you should output the most right digit of N^N.

 

 

Input

The inputcontains several test cases. The first line of the input is a single integer Twhich is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

 

 

Output

For each testcase, you should output the rightmost digit of N^N.

 

 

Sample Input

2

3

4

 

 

Sample Output

7

6

 

Hint

 

In the first case, 3 * 3 * 3 = 27, so the rightmost digitis 7.

In the second case, 4 * 4 * 4 * 4 = 256, so the rightmostdigit is 6.

 

 

 

Author

Ignatius.L

 

 

Recommend

We havecarefully selected several similar problems for you:  1019 1071 1170 1005 1425 

 

 思路:

利用快速幂,简单的模板题



代码:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<algorithm>
#define MYDD 1103

using namespace std;

long long MOD(long long x,long long n,long long mod) {
	long long ans;
	if(n==0)
		return 1;
	ans=MOD(x*x%mod,n/2,mod);//采用递归
	if(n&1)//用于判断 n 的二进制最低位是否为 1
		ans=ans*x%mod;
	return ans;
}

int main() {
	int t;
	long long n,ans;
	scanf("%d",&t);
	while(t--) {
		scanf("%lld",&n);
		ans=MOD(n,n,10);
		printf("%lld\n",ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值