NUBT 1651 Red packet(红包问题,二分,宁波工程学院在线评测)

  • [1651] Red packet

  • 时间限制: 1000 ms 内存限制: 65535 K
  • 问题描述
  • New Year is coming! Our big boss Wine93 will distribute some “Red Package”, just like Alipay and Wechat.

    Wine93 has m yuan, he decides to distribute them to n people and everyone can get some money(0 yuan is not allowed and everyone’s money is an integer), Now k people has gotten money, it’s your turn to get “Red Package”, you want to know, at least how much money to give you, then you can must become the “lucky man”. and the m yuan must be used out.

    Noting that if someone’s money is strictly much than others’, than he is “lucky man”.


  • 输入
  • Input starts with an integer T (T <= 50) denoting the number of test case.
    For each test case, three integers n, m, k (1 <= k < n <= 100000, 0< m <= 100000000) will be given.
    Next line contains k integers, denoting the money that k people get. You can assume that the k integers’ summation is no more than m.
  • 输出
  • Ouput the least money that you need to become the “lucky man”, if it is impossible, output “Impossible” (no quote).
  • 样例输入
  • 3
    3 5 2
    2 1
    4 10 2
    2 3
    4 15 2
    3 5
    
  • 样例输出
  • Impossible
    4
    6


思路:

发红包有成为幸运儿的说法即你要比每个人得到的红包都要多,你就是幸运儿。


输入数据:

测试数据个数

人数,红包总额,已经分发的人数

已经分发的人数的红包


思路:

代码注释部分。


如果描述不清晰:

博主参考自:Classmata_Wang Yinggang


代码:

#include<cstdio>
#include<cstdlib>
#define MYDD 1103

int MAX(int x,int y) {
	return x>y? x:y;
}

int main() {
	int t;
	scanf("%d",&t);
	while(t--) {
		int n,m,k;//人数,红包总额,已经分发的人数
		int max_get,distri_money,money;
		scanf("%d%d%d",&n,&m,&k);

		max_get=0;//当前已分发红包的最高金额
		distri_money=0;//已经分发红包的总额
		for(int j=0; j<k; j++) {
			scanf("%d",&money);
			distri_money+=money;
			max_get=MAX(max_get,money);//已经得到红包的最大金额
		}
		int remaining_money=m-distri_money;//剩下的金额
		if(remaining_money<=max_get) {
			puts("Impossible");//剩下的红包不大于已经得到红包的最大金额
			continue;
		}

		int remaining_people=n-k-1;//没发到红包的人数(不包含幸运儿)
		if(remaining_people==0) {//此时没有剩下没发的红包
			printf("%d\n",remaining_money);
		}

		int left=max_get+1;//二分求解满足条件
		int right=remaining_money;
		while(left<=right) {
			int middle=(left+right)/2;
			int k=remaining_money-middle-remaining_people+1;
			if(k<middle)
				right=middle-1;
			else
				left=middle+1;
		}

		printf("%d\n",left);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值