HDU 1301 / POJ 1251 Jungle Roads(最小生成树)

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 23971 Accepted: 11240

Description


The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems. 

Input

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above. 

Output

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit. 

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30

Source



题意:

维修公路确实很费钱,干嘛不重新修呢!!修修补补的注定坑钱。

回到题目,就是给定一些节点,和各个节点边的权值,问最小的维修费用。


思路:

以前看过这个题目,也就是除了题目长!没怎么看。

今天一看,测试数据都是问题,原来每行第一个字母后面跟的第一个数字是连通的边数!

看懂后才发现,就一水题昂,字母转化为数字不久直接处理了。结果还1A了!

做题少,没办法!


代码:

HDOJ 0MS 1432K 

POJ 404K 0MS

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int MYDD=1103+1e4;

int set[MYDD];
void init(int x) {//并查集初始化操作
	for(int j=1; j<=x; j++)
		set[j]=j;
}

int find(int x) {//并查集查找操作
	int child=x,t;
	while(x!=set[x])
		x=set[x];
	while(x!=child) {
		t=set[child];
		set[child]=x;
		child=x;
	}
	return x;
}

bool combine(int x,int y) {//并查集并操作
	int fx=find(x);
	int fy=find(y);
	if(fx==fy)//形成环
		return false;
	else {
		set[fx]=fy;
		return true;
	}
}

struct QS {//边的信息
	int u,v,w,vis;//vis 标记当前节点是否已经有边
} edge[MYDD*2];
bool cmp(QS x,QS y) {
	return x.w<y.w;
}

int main() {
	int N;
	while(scanf("%d",&N)&&N) {
		init(N);//没有初始化,找了半天的BUG
		int dd=1;//记录边
//		printf("&&&&&&&&&&&&还爆内存!!33333\n");
		for(int j=1; j<N; j++) {//数据的采集
			char nameu[4];//村庄序号
			int num;//连通的个数
			scanf("%s%d",nameu,&num);

			for(int i=0; i<num; i++) {
				edge[dd].u=nameu[0]-'A'+1;//起始边

				char namev[4];//连通的村庄序号
				int dis;//距离
				scanf("%s%d",namev,&dis);
				edge[dd].v=namev[0]-'A'+1;//终止边
				edge[dd].w=dis;
				dd++;

//				printf("&&&&&&&&&&&&还爆内存!!111\n");
			}

		}

		sort(edge+1,edge+dd+1,cmp);//数据的处理
		int ans=0;
		for(int j=1; j<=dd; j++) {
			if(combine(edge[j].u,edge[j].v)) {
				ans+=edge[j].w;
			}
//			printf("&&&&&&&&&&&&还爆内存!!33333\n");
		}
		printf("%d\n",ans);
	}
	return 0;
}
 


后:

******

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值