POJ 1258 Agri-Net(最小生成树)

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 51740 Accepted: 21580

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

Source



题意:

 和 POJ 2421 Constructing Roads (点击)类似。也是以矩阵的形式给出节点间的距离。

但是有道翻译成这样也是学习了!


思路:

使我头痛的事,统计边的数组下标若是从 1 计数,无限次的 错错错!最后参考了小师父的代码,下标 从0试试,结果就过了!!!


代码:

#include<stdio.h>
#include<algorithm>
#include<string.h>
#define ll long long
using namespace std;
const int MYDD=1103+1e4;

int set[MYDD];
void init(int x) {//并查集的初始化
	for(int j=1; j<=x; j++)
		set[j]=j;
}

int find(int x) {//并查集的查操作
	int t,child=x;
	while(x!=set[x])
		x=set[x];
	while(child!=x) {//路径压缩
		t=set[child];// t 记录当前父节点
		set[child]=x;
		child=t;
	}
	return x;
}

bool combine(int x,int y) {//并查集的并操作
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy) {
		set[fx]=fy;
		return true;//不成环
	}
	return false;
}

struct EDGE {
	int u,v,w;//vis 标记当前节点是否已经有边
} edge[MYDD];
bool cmp(EDGE x,EDGE y) {
	return x.w<y.w;
}

int main() {
	int n;
	while(scanf("%d",&n)!=EOF) {
		init(n);
		int dd=0;
		for(int j=1; j<=n; j++) {
			for(int k=1; k<=n; k++) {
				edge[dd].u=j;
				edge[dd].v=k;//边的存储
				scanf("%d",&edge[dd].w);
				dd++;
			}
		}

		sort(edge,edge+dd,cmp);//数据处理

		ll ans=0;//记录答案
		int count=0;
		for(int j=0; j<dd; j++) {//这里用count统计导致运行错误
			if(combine(edge[j].u,edge[j].v)) {
				ans+=edge[j].w;
				count++;
				if(count==n-1)
					break;
			}
		}
		printf("%lld\n",ans);
	}
	return 0;
}


错误代码留做纪念:

#include<stdio.h>
#include<algorithm>
#include<string.h>
#define ll long long
using namespace std;
const int MYDD=1103+1e4;

int set[MYDD];
void init(int x) {//并查集的初始化
	for(int j=1; j<=x; j++)
		set[j]=j;
}

int find(int x) {//并查集的查操作
	int t,child=x;
	while(x!=set[x])
		x=set[x];
	while(child!=x) {//路径压缩
		t=set[child];// t 记录当前父节点
		set[child]=x;
		child=t;
	}
	return x;
}

bool combine(int x,int y) {//并查集的并操作
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy) {
		set[fx]=fy;
		return true;//不成环
	}
	return false;
}

struct EDGE {
	int u,v,w;//vis 标记当前节点是否已经有边
} edge[MYDD*2];
bool cmp(EDGE x,EDGE y) {
	return x.w<y.w;
}

int main() {
	int n;
	while(scanf("%d",&n)!=EOF) {
		init(n);
		int dd=1;
		for(int j=1; j<=n; j++) {
			for(int k=1; k<=n; k++) {
				edge[dd].u=j;
				edge[dd].v=k;//边的存储
				scanf("%d",&edge[dd].w);
				dd++;
			}
		}

		sort(edge+1,edge+dd+1,cmp);//数据处理

		ll ans=0;//记录答案
		int count=0;
		for(int j=1; j<=dd; j++) {//这里用count统计导致运行错误
			if(combine(edge[j].u,edge[j].v)) {
				ans+=edge[j].w;
				count++;
				if(count==n-1)
					break;
			}
		}
		printf("%lld\n",ans);
	}
	return 0;
}

后:

****************

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值