HDU 1058 Humble Numbers(丑数,优先队列,STL)

http://acm.hdu.edu.cn/showproblem.php?pid=1058

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24358    Accepted Submission(s): 10675


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
  
  
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

Sample Output
  
  
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.

题意:

丑数的定义(这里不同于数论的丑数定义),本题目类似于 UVA136 (点击链接到)。

该题目丑数是只含有素因数为2,3,5,7的数。键入 n 值,输出第 n 个丑数。

思路:

最小的丑数是 1,而对于任意丑数 x ,有2x, 3x, 5x, 7x也都是丑数。此时使用一个优先队列保存已经生成丑数中的最小丑数,再次生成 4 个丑数....

注意的是需要判断丑数是否已经生成。

注:数字后的英语字母!!!

AC CODE:

#include<stdio.h>
#include<cstring>
#include<vector>
#include<queue>
#include<set>
#include<algorithm>
#define HardBoy main()
#define ForMyLove return 0;
typedef long long LL;
using namespace std;
const int MYDD = 1103+5842;

LL ans[MYDD];
int base[4] = {2, 3, 5, 7};
void Init() {
	priority_queue< LL, vector<LL>, greater<LL> > pq;
	set<LL> s;
	pq.push(1);
	s.insert(1);
	for(int j = 1; j <= 5842; j++) {
		LL x = pq.top();
		ans[j] = x;
		pq.pop();
		for(int j = 0; j < 4; j++) {
			LL x2 = x*base[j];
			if(!s.count(x2)) {
				s.insert(x2);
				pq.push(x2);
			}
		}
	}
}

int HardBoy {
	Init();
	int n;
	while(scanf("%d", &n) && n) {
//		printf("The %dth humble number is %d.\n", n, ans[n]);
		if(n%10==1&&n%100!=11)
			printf("The %dst humble number is %d.\n", n, ans[n]);
		else if(n%10==2&&n%100!=12)
			printf("The %dnd humble number is %d.\n", n, ans[n]);
		else if(n%10==3&&n%100!=13)
			printf("The %drd humble number is %d.\n", n, ans[n]);
		else
			printf("The %dth humble number is %d.\n", n, ans[n]);
	}
	ForMyLove
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值