通达信精准选股公式

 

通达信精准选股公式:

 

 

 

条件选股公式源码
年认同价:=MA(C,240);
价格中枢:=(SUM(年认同价,0)/(BARSSINCE(年认同价>0)+239));
箱顶:=价格中枢*1.2;
箱底:=价格中枢*0.8;
毛利润率:=FINANCE(21)/FINANCE(20);
成长价值:=年认同价*(1+毛利润率);
收益价值:=年认同价+FINANCE(33);
回调认同:=EMA(EXPMA(C,20),13);
多头:=(回调认同>REF(回调认同,1))AND(成长价值>REF(成长价值,1))AND(收益价值>REF(收益价值,1))AND(DYNAINFO(7)>0);
回调条件:=COUNT(C<回调认同,5)>=3;
回调突破:=(REF(C,1)<=REF(回调认同,1))AND(C>回调认同)AND(回调条件)AND 多头;
成长条件:=COUNT(C<成长价值,5)>=3;
成长突破:=(REF(C,1)<=REF(成长价值,1))AND(C>成长价值)AND(成长条件)AND 多头;
收益条件:=COUNT(C<收益价值,5)>=3;
收益突破:=(REF(C,1)<=REF(收益价值,1))AND(C>收益价值)AND(收益条件)AND 多头;
箱底条件:=COUNT(C<箱底,5)>=3;
箱底突破:=(REF(C,1)<=REF(箱底,1))AND(C>箱底)AND(箱底条件)AND 多头;
价格条件:=COUNT(C<价格中枢,5)>=3;
价格突破:=(REF(C,1)<=REF(价格中枢,1))AND(C>价格中枢)AND(价格条件)AND 多头;
箱顶条件:=COUNT(C<箱顶,5)>=3;
箱顶突破:=(REF(C,1)<=REF(箱顶,1))AND(C>箱顶)AND(箱顶条件)AND 多头;
突破买点:(回调突破+成长突破+收益突破+箱底突破+价格突破+箱顶突破);

专买老鼠仓
{
老鼠仓}
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(FF1,(LOW* 0.97),'
老鼠仓'),COLOR4080FF;
老鼠仓是个很不错的指标,信号发出一般都在一个波段的底部起涨之时。
根据本人的实践,使用指标时候要注意几点:
1
该指标可以添加到任何一个主图里面去,比如MA均线什么的。
2
出现信号当天买进股票,第二天收阳继续持股,直到出阴为止。
3
第二天出阴考虑卖出,非常适合短线操作!

老鼠仓(选股公式)
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
老鼠仓:BB1 AND CC1 AND DD1 AND EE1;

理想选股(选股公式)
VAR1:=MA((LOW+HIGH+CLOSE)/3,5);
VAR2:=CLOSE=HHV(C,4) AND REF(C,1)=LLV(C,4);
VAR3:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
VAR4:=VAR1>REF(VAR1,1) AND REF(VAR1,1)<REF(VAR1,2);
VAR5:=LOW<HHV(VAR1,13) AND HIGH>HHV(VAR1,13) AND CLOSE>REF(C,1) AND CLOSE>OPEN;
VAR6:=VAR5 AND COUNT(VAR4,2);
VAR7:=VAR6 AND NOT(REF(VAR6,1));
VAR8:=100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6);
VAR9:=EMA(MA(C,13),13);
VAR10:=FILTER((LLV(VAR8,2)=LLV(VAR8,7) AND COUNT(VAR8<0,2) AND CROSS(VAR8,MA(VAR8,2)))=1,5);
VAR11:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
VAR12:=FILTER(((CROSS(VAR11,0) OR CROSS(C,VAR9)) AND VAR10)=1,3);
VAR13:=MA(C,18)>=REF(MA(C,18),3) AND CROSS(C,MA(C,18));
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
金叉:=CROSS(J,D);
死叉:=CROSS(D,J);
1:=(VAR12 OR VAR13) AND VAR10;
2:=(VAR12 OR VAR13) AND VAR3;
3:=(VAR12 OR VAR13) AND VAR2;
4:=(VAR2 AND VAR10) OR (VAR3 AND VAR10);
5:=(金叉 AND VAR3) OR (金叉 AND VAR2) OR (金叉 AND VAR10);
ST:=EXIST(C/REF(C,1)>1.06,50);
输出:=(1 OR 2 OR 3 OR 4 OR 5 OR VAR7) AND ST;
MA5:=MA(C,5),COLORWHITE;
X:=(3*C+L+O+H)/6;
多空线:=(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)
+13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)
+7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+
REF(X,20))/210,COLORFF00FF,LINETHICK1;
AB:=DRAWLINE(HIGH>=HHV(HIGH,10),HIGH,LOW<=LLV(LOW,3),HHV(HIGH,3),1),COLORYELLOW;
CROSS(MA5,
多空线) and CROSS(C,AB) and 输出 ;

点石成金(选股公式)
KS13:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*(-100);
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
FASTK:=SMA(RSV,3,1);K:=SMA(FASTK,3,1);D:=SMA(K,5,1);
Var1:=CLOSE/MA(CLOSE,40)*100<76;
Var2:=CLOSE/MA(CLOSE,60)*100<74;
Var3:=HIGH>LOW*1.051;
Var4:=Var3 AND COUNT(Var3,5)>1;
Var4 AND (Var1 OR Var2) AND REF(KS13,1)>=10 AND REF(KS13,1)/KS13>=1.13 AND
CLOSE/REF(CLOSE,1)>=1.02;

牛市绝底(选股公式)
VAR1:=REF(CLOSE,1);
VAR2:=((SMA(MAX((CLOSE - VAR1),0),7,1) / SMA(ABS((CLOSE - VAR1)),7,1)) * 100);
VAR3:=((SMA(MAX((CLOSE - VAR1),0),13,1) / SMA(ABS((CLOSE - VAR1)),13,1)) * 100);
VAR4:=((100 * (HHV(HIGH,48) - LOW)) / HHV(HIGH,48));
VAR5:=((100 * (HIGH - LLV(LOW,48))) / LLV(LOW,48));
牛市绝底:VAR2 < 15 AND VAR3 < 20 AND (VAR2 + VAR3) > 20 AND VAR4 > 40 AND BARSCOUNT(CLOSE) > 47;

飞弹一号(选股公式)
var1:=c/ma(c,40)*100<78;
var2:=c/ma(c,60)*100<74;
var3:=h>=l*1.051;
var4:=var3 and count(var3,5)>=2;
xg:var4 and (var1 or var2) and count(h=l and c=o and c<ref(c,1),3)=0
and hhv(v/capital,30)<0.8;

牛魔无双(选股公式)
A4:=(HIGH-LOW)/HIGH*100+(C-REF(C,1))/REF(C,1)*100;
B4:=EMA(MA(A4,50),5);
c4:=B4>LLV(B4,5)*1.01 AND REF(B4,1)<REF(LLV(B4,5),1)*1.01
AND LLV(B4,50)=LLV(B4,5);
d4:=LLV(LOW,5)=LLV(LOW,50) AND LLV(LOW,5)<HHV(LOW,70)*0.5;
xg:c4 AND d4;

火牛神功(选股公式)
Var1:=DMA(CLOSE,VOL/SUM(VOL,34));
Var2:=DMA(CLOSE,VOL/SUM(VOL,13));
Var3:=(CLOSE-Var1)/Var1*100;
Var4:=(CLOSE-Var2)/Var2*100;
Var4<=-12 AND Var3<=-19 ;

跟庄建仓(选股公式)
A01:=DYNAINFO(7);
A03:=BARSCOUNT(CLOSE);
A04:=(SMA((CLOSE / HHV(HIGH,120)),3,1) * 100);
A05:=IF((A03 > 20),A04,0);
A06:=IF((LOW > A01),0,IF((HIGH < A01),1,(((A01 - LOW) + 0.009) / ((HIGH - LOW) + 0.009))));
A07:=DMA(A06,(VOL / CAPITAL)) * 60;
A09:=IF((((A07 > 0) AND (A07 > REF(A07,1))) AND (A05 <= 88)),A07,0);
Var3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势:=EMA(Var3,3)-10;
机构建仓区:=(A09 > 0 AND (趋势<20 OR 趋势>REF(趋势,1)AND 趋势<50));
Var7:=LLV(LOW,30);
Var11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
Var12:=HHV(Var11,30)*8;
火焰山:=EMA(IF(LOW<=Var7 AND 趋势<40,(Var11+Var12),0),3)/618;
选股:火焰山>0 AND 机构建仓区>0 AND 趋势>REF(趋势,1) AND REF(趋势,1)<REF(趋势,2);

跟庄建仓源码
A01:=DYNAINFO(7);
A03:=BARSCOUNT(CLOSE);
A04:=(SMA((CLOSE / HHV(HIGH,120)),3,1) * 100);
A05:=IF((A03 > 20),A04,0);
A06:=IF((LOW > A01),0,IF((HIGH < A01),1,(((A01 - LOW) + 0.009) / ((HIGH - LOW) + 0.009))));
A07:=DMA(A06,(VOL / CAPITAL)) * 60;
A09:=IF((((A07 > 0) AND (A07 > REF(A07,1))) AND (A05 <= 88)),A07,0);
Var1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
Var2:=EMA(Var1,8);
Var3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势:=EMA(Var3,3)-10;
STICKLINE(
趋势>80,趋势,80,5,0);
DRAWICON(CROSS(
趋势,0),0,1);
STICKLINE((A09 > 0 AND (
趋势<20 OR 趋势>REF(趋势,1)AND 趋势<50)),0,A09,6,0),colorFFff00;
机构建仓区:0,LINETHICK0,colorFFFF00;
Var4:=(
趋势-REF(趋势,1))/REF(趋势,1)*100;
STICKLINE(
趋势<=13,0,20,3,0),colorcc9900;
DRAWTEXT(FILTER(
趋势<=13,15),30,'准备现金'),colorcc9900;
STICKLINE(
趋势<=13 AND Var4>13,0,50,2,0),color0099ff;
Var5:=FILTER((
趋势<=13 AND Var4>13),10);
DRAWTEXT(Var5,60,'
买入'),color0099ff;
STICKLINE(
趋势>=90 AND Var4,0,30,3,0),colorgray;
Var6:=FILTER((
趋势>=90 AND Var4),10);
DRAWTEXT(Var6,40,'
清仓'),colorgray;
Var7:=LLV(LOW,30);
Var8:=HHV(HIGH,30);
Var9:=EMA((CLOSE-Var7)/(Var8-Var7)*4,4)*25;
STICKLINE(Var9>90,100,105,3,2),COLORRED;
Var10:=(Var9-LLV(Var9,4))/(HHV(Var9,4)-LLV(Var9,4))*100;
DRAWTEXT(IF(CROSS(Var9,Var10) AND Var9>87,95,0),88,'
'),Color00FF00;
DRAWICON(CROSS(90,Var9),95,9);
Var11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
Var12:=HHV(Var11,30)*8;
火焰山:EMA(IF(LOW<=Var7 AND 趋势<40,(Var11+Var12),0),3)/618,COLORRED,linethick2;
STICKLINE(
火焰山>0,0 ,火焰山*1.2,4,0 ),COLORRED;
Var13:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;
Var14:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;
趋势线: 趋势,colorff0000;
Var16:=MAX(EMA(Var13,2)-EMA(Var14,5),0)*200;
Var17:=EMA(Var16,5);
波浪峰:Var17,stick,colorff00ff;
STICKLINE(Var17<REF(Var17,1),0,Var17,1,0),color00ff00;
Var18:=MA(
趋势线,8);
if(CROSS(Var2,Var18) AND Var2<15,50,0),COLORRED;
DRAWTEXT(CROSS(
趋势线,Var2)AND 趋势线>REF(趋势线,1)AND 趋势线<50,50,'追涨'),COLORff00ff;
风险区:IF(趋势>80,趋势,80),colorff00ff;

双信号"全仓"选股(选股公式)
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
TTJ:=CROSS(FF,MA15);
:=EMA(C,3),COLORBLUE,LINETHICK1;
:=EMA(C,5),COLORWHITE,LINETHICK1;
:=EMA(,5),COLOR00FF00,LINETHICK1;
QQ:= C<
;
MM:=
>REF(,1) AND REF(,1)<REF(,2) ;
V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
V2:=(1-7/100)*(DMA(CLOSE,V1));
V3:=(1+7/100)*(DMA(CLOSE,V1));
V5:=MA((LOW+HIGH+CLOSE)/3,5);
MA1:=MEMA(CLOSE,5);
MA2:=ATAN((MA1/REF(MA1,1)-1)*100)*180/3.1416;
MA3:=IF(MA2>0,MA2,MA2);
MA5:=MA(CLOSE,5),COLOR888899;
MA13:=MA(CLOSE,13),COLORFF00F0,LINETHICK2;
VAR01:=CLOSE=HHV(C,4) AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF(C,3))
OR REF(C,1)=HHV(C,4) AND CLOSE>=REF(C,2) OR REF(C,2)=HHV(C,4) AND
REF(C,3)=LLV(C,4) AND C>=REF(C,1) OR REF(C,3)=HHV(C,4) AND
C>=REF(C,1) AND C>=REF(C,2);
{
收盘价=4日内收盘价的最高值 AND 昨收>=2日前的收盘价}
VAR02:=CLOSE=HHV(C,4) AND REF(C,1)=LLV(C,4);
{
收盘价=4日内收盘价的最高值 AND 昨收=4日内收盘价的最低值}
VAR03:=CLOSE=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR
REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND
REF(C,1)=HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND
C<REF(C,1) AND C<REF(C,2);
{
收盘价=4日内收盘价的最低值 AND (昨收<2日前的收盘价}
VAR04:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND
REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
{
昨收=4日内收盘价的最低值 AND 收盘价>=2日前的收盘价}
VAR05:=REF(C,1)=HHV(C,4) AND C<REF(C,2) OR (REF(C,2)=HHV(C,4) AND
REF(C,1)>REF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)>REF(C,2)) AND
REF(C,2)>=REF(C,4) AND C<REF(C,1);
{
昨收=4日内收盘价的最高值 AND 收盘价<2日前的收盘价}
VAR06:=V5>REF(V5,1) AND REF(V5,1)<REF(V5,2);
{
今日V5向上形成拐点}
VAR07:=LOW<HHV(V5,13) AND HIGH>HHV(V5,13) AND CLOSE>REF(C,1) AND CLOSE>OPEN;
VAR08:=VAR07 AND COUNT(VAR06,2);
VAR09:=100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6);
VAR10:=EMA(MA(C,13),13);
VAR11:=FILTER((LLV(VAR09,2)=LLV(VAR09,7) AND COUNT(VAR09<0,2) AND
CROSS(VAR09,MA(VAR09,2)))=1,5);
VAR12:=FILTER((HHV(VAR09,2)=HHV(VAR09,7) AND COUNT(VAR09>50,2) AND
CROSS(MA(VAR09,2),VAR09))=1,1);
VAR13:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
VAR14:=FILTER(((CROSS(VAR13,0) OR CROSS(C,VAR10)) AND VAR11)=1,3);
VAR15:=MA(C,18)>=REF(MA(C,18),3) AND CROSS(C,MA(C,18));
VAR16:=VAR08 AND NOT(REF(VAR08,1));
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
金叉:=CROSS(J,D);
死叉:=CROSS(D,J);
1:=(VAR14 OR VAR15) AND VAR11;
2:=(VAR14 OR VAR15) AND VAR04;
3:=(VAR14 OR VAR15) AND VAR02;
4:=(VAR02 AND VAR11) OR (VAR04 AND VAR11);
5:=(金叉 AND VAR04) OR (金叉 AND VAR02) OR (金叉 AND VAR11);
TTJ0:=VAR16;
TTJ1:=
1 OR 2 OR 3 OR 4 OR 5 AND MM;
XG0:=TTJ AND TTJ0;
XG1:=TTJ AND TTJ1;
XG11:=XG0 OR XG1;
{
以下波浪理论浪底重叠"买底"选股原码}
PL5:=ZIG(3,5);
EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
EX1:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
PL10:=ZIG(3,10);
EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);
EX2:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);
PL20:=ZIG(3,20);
EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);
EX3:=ZIG(3,20)<REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)>=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);
PL40:=ZIG(3,40);
走强1:=BARSLAST(PL5<REF(PL5,1));
走弱1:=BARSLAST(PL5>REF(PL5,1));
走强2:=BARSLAST(PL10<REF(PL10,1));
走弱2:=BARSLAST(PL10>REF(PL10,1));
走强3:=BARSLAST(PL20<REF(PL20,1));
走弱3:=BARSLAST(PL20>REF(PL20,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,
走强2),0);
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,
走强2),0);
DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,
走弱2),0);
DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,
走弱2),0);
ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,
走强3),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,
走强3),0);
DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,
走弱3),0);
DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,
走弱3),0);
TJ11:=EN2 AND ZTJZ5=1;
TJ22:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2;
TJ33:=EN2 AND DTJZ10=1;
TJ44:=EN3 AND ZTJZ10=1;
TJ55:=EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2;
XG22:=TJ11 OR TJ22 OR TJ33 OR TJ44 OR TJ55;
{
以下二者结合共同选股}
XG:=XG11 OR XG22;
W18:EXIST(XG,1);

涨停板敢死队(选股公式)
Lx1:=(EMA((AMOUNT/10000000),1) /3);
Lx2:=(WINNER(C)/0.3);
Lx3:=IF(c<0,Lx1,V);
Lx4:=IF(c<0,Lx2,V);
Lx5:=IF((BARSCOUNT(C)>100),Lx3,Lx4);
:=Lx5/1000;
动量:=(EMA(,13)*1.5);
A01:=IF((
>动量),,0);
A02:=BARSLAST((A01>0));
A03:=REF(
,A02);
趋势:=IF((<=A01),,A03);
突破:=IF(((((=趋势) and (C>REF(C,1))) and (>REF(,1))) and (REF(A02,2)>0)),888,0);
量价突破:FILTER(突破 ,5 )*6;

 

 

 

 

 

 

 

 

 

通达信选股公式:

 

 

 

超级牛魔
VAR3:=1;
VAR4:=MA(CLOSE,5);
VAR5:=MA(CLOSE,10);
VAR6:=MA(CLOSE,30);
VAR7:=MA(CLOSE,60);
VAR8:=EMA(COST(85),7);
VAR9:=EMA(COST(15),7);
VARA:=SUM(CLOSE*VOL*100,4)/SUM(VOL*100,4);
VARB:=INTPART(VARA*100)/100;
VARC:=SUM(CLOSE*VOL*100,7)/SUM(VOL*100,7);
VARD:=INTPART(VARC*100)/100;
VARE:=SUM(CLOSE*VOL*100,28)/SUM(VOL*100,28);
VARF:=INTPART(VARE*100)/100;
短线趋势:=EMA(CLOSE,5)-EMA(CLOSE,10);
中线趋势:=EMA(短线趋势,30);
VAR10:=-100*(HHV(CLOSE,5)-CLOSE)/(HHV(CLOSE,5)-LLV(LOW,5))+100;
VAR11:=-100*(HHV(CLOSE,10)-CLOSE)/(HHV(CLOSE,10)-LLV(LOW,10))+100;
VAR12:=-100*(HHV(CLOSE,20)-CLOSE)/(HHV(CLOSE,20)-LLV(LOW,20))+100;
VAR13:=-100*(HHV(CLOSE,30)-CLOSE)/(HHV(CLOSE,30)-LLV(LOW,30))+100;
VAR14:=REF(
中线趋势,1);
VAR15:=
中线趋势;
VAR16:=VAR15-VAR14;
VAR17:=REF(
短线趋势,1);
VAR18:=
短线趋势;
VAR19:=VAR18-VAR17;
VAR1A:=OPEN;
VAR1B:=CLOSE;
超级牛魔王:IF(VAR1A<=VAR4 AND VAR1A<=VAR5 AND VAR1A<=VAR6 AND VAR1B>=VAR4 AND VAR1B>=VARF AND VAR16>0 AND VAR19>0 AND VAR3=1,0.5,0);

盘中参考
VAR3:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR4:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR27:=VAR3<REF(VAR4,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
关注:VAR27 AND COUNT(VAR27,30)=1;

 

初升介入1
V1:=(C-LLV(L,20))/(HHV(H,20)-LLV(L,20))*100;
V2:=SMA(V1,20,1);
V3:=SMA(V2,15,1);
V4:=(3*V2+2*V3)/4;
V5:= REF(V4,1);
RSA:=SMA(MAX(V4-V5,0),2,1)/SMA(ABS(V4-V5),2,1)*100;
RSB:=MA(RSA,10);
AA:=VOL/REF(VOL,1)>2;
BB:=CLOSE/REF(CLOSE,1)>1.07;
初升介入:IF(AA AND BB,CROSS(RSA,RSB),DRAWNULL);

主力介入
VAR1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR4:=(VAR1+2*VAR2+3*VAR3)/6;
VAR5:=MA(VAR4,3)-STD(VAR4,3);
VARA:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(VARA,3,1),COLORYELLOW;
VARB:=SMA(K,3,1);
J:=3*K-2*VARB,COLORGREEN;
主力介入: CROSS(J,VARB) AND COUNT(VAR5<-16,4)>=1,COLORWHITE;

旺狗出击
旺狗出击:CROSS(C,MA(CLOSE,55) + 2*STD(CLOSE,55)) AND C>O  
AND VOL>1.6*REF(VOL,1) AND VOL>=2*MA(VOL,60) AND
EMA(WINNER(C)*70,3)>EMA((WINNER(C*1.1)-WINNER(C*0.9))*70,3)
AND VOL>=1.6*MA(VOL,5) ;

 

五线选股
AVR1:=EMA(CLOSE,10);
AVR2:=(46.18*EMA(CLOSE,10)-31.82*EMA(CLOSE,4))/14.36;
AVR3:=MA(CLOSE,9);
AVR4:=MA(CLOSE,20);
五线选股:IF(CROSS(AVR1,AVR4) AND CROSS(AVR3,AVR4) AND CROSS(AVR4,AVR2),1,0);

狂牛启动1
VARE:=(C-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
SOLE:=SMA(SMA(VARE,3,1),3,1);
BUY:=3*SMA(VARE,3,1)-2*SOLE;
SCCOUNT:=COUNT(BARSLAST(CROSS(SOLE,BUY)),BARSLAST(CROSS(SOLE,BUY)));
选股1:BUY>SOLE AND REF(BUY,1)<REF(SOLE,1);

狂牛启动2
VARE:=(C-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
SOLE:=SMA(SMA(VARE,3,1),3,1);
BUY:=3*SMA(VARE,3,1)-2*SOLE;
SCCOUNT:=COUNT(BARSLAST(CROSS(SOLE,BUY)),BARSLAST(CROSS(SOLE,BUY)));
选股2:CROSS(BUY,SOLE) AND REF(SOLE,1)/REF(BUY,1)<=1.5 AND SOLE<64 AND SCCOUNT=1;

狂牛启动3
VAR2:=1;
VAR3:=REF(HIGH,1)*1.1;
VAR4:=HIGH*1.1;
VAR5:=(VAR4*VOL+VAR3*(CAPITAL-VOL))/CAPITAL;
VAR6:=REF(LOW,1)*0.9;
VAR7:=LOW*0.9;
VAR8:=(VAR7*VOL+VAR6*(CAPITAL-VOL))/CAPITAL;
VAR9:=EMA(VAR8,30);
VARA:=EMA(VAR5,30);
VARB:=VARA-2;
VARC:=IF(C<=VAR9,VARB,VARA);
VARD:=MA(C,80)-MA(C,10)/17;
准备:=STICKLINE(VARC-VARB=0 AND VAR2 AND CROSS((EMA(EMA(EMA(C,2),2),2)-REF(EMA(EMA(EMA
(C,2),2),2),1))/REF(EMA(EMA(EMA(C,2),2),2),1)*100,MA((EMA(EMA(EMA(C,2),2),2)-REF(EMA(EMA
(EMA(C,2),2),2),1))/REF(EMA(EMA(EMA(C,2),2),2),1)*100,3)),50,0,5,0);
选股3: FILTER(VARC-VARB=0 AND CROSS((EMA(EMA(EMA(C,2),2),2)-REF(EMA(EMA(EMA(C,2),2),2),1))/REF(EMA(EMA(EMA(C,2),2),2),1)*100,MA((EMA(EMA(EMA(C,2),2),2)-REF(EMA(EMA(EMA(C,2),2),2),1))/REF(EMA(EMA(EMA(C,2),2),2),1)*100,3)),4);

 

短线通道
VAR1:=(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100))*200;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=3*VAR2-2*VAR3;
VAR5:=LLV(LOW,5);
VAR6:=HHV(HIGH,5);
VAR7:=EMA((CLOSE-VAR5)/(VAR6-VAR5)*100,4)*2;
VAR8:=EMA(0.667*REF(VAR7,1)+0.333*VAR7,2);
VAR9:=3*VAR7-2*VAR8;
VARA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VARB:=POW(MA(LOW,5),2)+MA(LOW,5);
VARC:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARD:=(VARA-LLV(VARB,64))/(HHV(VARC,64)-LLV(VARB,64))*150+65-10;
VARE:=SMA(VARD,3,1)*1.5-100;
VARF:=SMA(VARE,3,1);
VAR10:=3*VARE-2*VARF;
VAR11:=(HIGH+LOW+CLOSE*2)/4;
VAR12:=EMA(VAR11,13);
VAR13:=STD(VAR11,13);
VAR14:=(VAR11-VAR12)*100/VAR13;
VAR15:=EMA(VAR14,5);
VAR16:=EMA(VAR15,13);
VAR17:=EMA(VAR15,13)+200-100;
VAR18:=EMA(VAR17,10);
VAR19:=3*VAR17-2*VAR18;
VAR1A:=VAR2+VAR7+VARE+VAR17;
VAR1B:=VAR3+VAR8+VARF+VAR18;
VAR1C:=VAR4+VAR9+VAR10+VAR19;
VAR1D:=(HIGH+LOW+CLOSE)/3;
VAR1E:=AMOUNT/VOL/100;
VAR1F:=SUM(AMOUNT,5)/SUM(VOL,5)/100;
VAR20:=(VAR1D-MA(VAR1D,34))/(0.015*AVEDEV(VAR1D,34));
VAR21:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
VAR22:=(HIGH+LOW+CLOSE+VAR1D)/4;
VAR23:=EMA(VAR22,24);
VAR24:=STD(VAR22,24);
VAR25:=(VAR22-VAR23)/VAR24*100;
VAR26:=(VAR1D-MA(VAR1D,24))/(0.015*AVEDEV(VAR1D,24));
VAR27:=EMA(VAR25,5);
VAR28:=(VAR1E-MA(VAR1E,21))/(0.015*AVEDEV(VAR1E,21));
VAR29:=(VAR1F-MA(VAR1F,90))/(0.015*AVEDEV(VAR1F,90));
VAR2A:=((VAR29+VAR28+VAR27+VAR26+VAR20)/5+165)/4;
VAR2B:=(VAR1A+VAR1B+VAR1C*30)/32/5-15;
VAR2C:=(VAR2A+VAR2B)/2/1.1;
短线:=VAR2C;
MID:=MA(
短线,26);
UPPER:=MID+2*STD(
短线,26);
LOWER:=MID-2*STD(
短线,26);
{LCJ2:=IF(
短线>MID,MID,短线); }
{
买点: DRAWICON(CROSS(短线,MID),MID*0.97,1); }
{DRAWICON(CROSS(
短线,LOWER),LOWER*0.97,3); }
{
卖点: DRAWICON(CROSS(UPPER,短线),UPPER*0.97,2);
MID, , COLORYELLOW;}
{
多头买入} ENTERLONG:CROSS(短线,MID) AND UPPER-MID>50;

出手就赢1
RSV:= (CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
CROSS(K,D) AND D<30;

出手就赢2
RSV:= (CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
CROSS(K,D) AND D<80;

 

套利狐狸
VAR1:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
VAR2:=REF(HIGH,10)/CLOSE>1.35;
V3: (CLOSE-VAR1)/VAR1*100<-30 AND VAR2;

乘胜追击1
VAR1:=WINNER(CLOSE)-WINNER(OPEN);
VAR2:=REF(CLOSE,1);
VAR3:=SMA(MAX(CLOSE-VAR2,0),5,1)/SMA(ABS(CLOSE-VAR2),5,1)*100;
VAR4:=CLOSE/MA(CLOSE,3)>=1.05;
VAR5:=MA(VOL,8)/MA(VOL,45)>=2.5;
VAR6:=WINNER(CLOSE)-WINNER(OPEN);
VAR7:=REF(CLOSE,1);
VAR8:=SMA(MAX(CLOSE-VAR7,0),5,1)/SMA(ABS(CLOSE-VAR7),5,1)*100;
VAR9:=VAR6>=0.3 AND MA(VOL,6)/MA(VOL,26)>=1.9 AND VOL>REF(VOL,1) AND COUNT(VAR8<20,20)>=1 AND   CLOSE/MA(CLOSE,3)>=1.07;
VARA:=VAR1>=0.4 AND VAR5 AND COUNT(VAR3<20,20)>=1 AND VAR4 AND CLOSE>MA(CLOSE,85) AND VOL>REF(VOL,1);
(VARA OR VAR9);

逆势操作1
VAR1:=DMA(CLOSE,VOL/MA(VOL,4)/4);
VAR2:=DMA(CLOSE,VOL/MA(VOL,32)/32);
VAR3:=(CLOSE-VAR1)/VAR1*100<-8;
VAR4:=(VAR1-VAR2)/VAR2*100<-21;
VAR5:=VAR3 AND VAR4 AND (OPEN>CLOSE OR OPEN<CLOSE) AND (OPEN-REF(CLOSE,1))/REF(CLOSE,1)>-0.05   AND   (REF(CLOSE,1)>REF(OPEN,1) OR REF(CLOSE,1)<REF(OPEN,1)) AND (REF(OPEN,2)>REF(CLOSE,2) OR REF(OPEN,2)<REF(CLOSE,2)) AND (REF(OPEN,3)>REF(CLOSE,3) OR REF(OPEN,3)<REF(CLOSE,3)) AND (REF(OPEN,4)>REF(CLOSE,4) OR REF(OPEN,4)<REF(CLOSE,4)) AND (REF(OPEN,5)>REF(CLOSE,5) OR REF(OPEN,5)<REF(CLOSE,5)) AND (REF(OPEN,6)>REF(CLOSE,6) OR REF(OPEN,6)<REF(CLOSE,6)) AND (REF(OPEN,7)>REF(CLOSE,7) OR REF(OPEN,7)<REF(CLOSE,7));
VAR6:=(CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100<-23;
VAR7:=(INDEXC-LLV(INDEXL,275))/(HHV(INDEXH,275)-LLV(INDEXL,275))*100;
VAR8:=SMA(VAR7,50,1);
VAR9:=SMA(VAR8,40,1);
VARA:=VAR6 AND VAR9<23 AND COUNT(VAR6,2)=1 AND (OPEN>CLOSE OR OPEN<CLOSE) AND OPEN/REF(CLOSE,1) >0.96 ;
(VAR5 OR VARA) ;

牛市专利1
VAR1:=REF(CLOSE,3)*0.844;
VAR2:=REF(CLOSE,13)*0.767;
VAR3:=INDEXC;
VAR4:=INDEXV;
VAR5:=MIN(VAR1,VAR2);
VAR6:=100*VOL/CAPITAL;
VAR7:=(CLOSE-MA(CLOSE,20))/MA(CLOSE,20)*100;
VAR8:=(CLOSE-VAR5)/CLOSE<0.07 AND SUM(VAR6,3)/3<2.345 AND VAR3>MA(VAR3,450) AND MA(VAR4,61)/MA(VAR4,80)>0.923 AND CLOSE>MA(CLOSE,190);
VAR9:=VAR3>MA(VAR3,450) AND VAR7<-16.5 AND MA(VAR4,61)/MA(VAR4,80)>0.92 AND CLOSE>MA(CLOSE,215)   AND (REF(OPEN,1)>REF(CLOSE,1) OR REF(OPEN,1)<REF(CLOSE,1)) AND (REF(OPEN,2)>REF(CLOSE,2) OR REF(OPEN,2)<REF(CLOSE,2)) AND (REF(OPEN,3)>REF(CLOSE,3) OR REF(OPEN,3)<REF(CLOSE,3)) AND (REF(OPEN,4)>REF(CLOSE,4) OR REF(OPEN,4)<REF(CLOSE,4)) AND (REF(OPEN,5)>REF(CLOSE,5) OR REF(OPEN,5)<REF(CLOSE,5)) AND VOL/CAPITAL<0.075;
(VAR8 OR VAR9);

 

同时金叉
DIF:=EMA(CLOSE,9)-EMA(CLOSE,17);
DEA:=EMA(DIF,8);
MACD:=(DIF-DEA)*2;
RSV:=(CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI3:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;
选股:CROSS(DIF,DEA) AND CROSS(J,D) AND CROSS(RSI1,RSI3);

带量突破
VAR1:=EMA(COST(80),10);
COUNT(CROSS(CLOSE,VAR1),2)>=1 AND VOL/CAPITAL>=0.1;

攻击箱顶
VAR1:=HHV(MA((LOW+HIGH+CLOSE+OPEN)/4,5),58);
BETWEEN(CLOSE,VAR1*1.001,VAR1) AND REF(VAR1,3)=VAR1 AND VOL>REF(VOL,2);

 

果断介入
VAR1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR4:=(VAR1+2*VAR2+3*VAR3)/6;
VAR5:=MA(VAR4,3)-STD(VAR4,3);
VAR6:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR7:=SMA(VAR6,3,1);
VAR8:=SMA(VAR7,3,1);
VAR9:=3*VAR7-2*VAR8;
CROSS(VAR9,VAR8) AND COUNT(VAR5<-12 AND VAR5>-14,3)>=1;

暴裂旋风
VAR1:=ABS(HIGH-LOW);
SUM(VAR1,7)/CLOSE>0.5 AND SUM(VAR1,7)/CLOSE<0.8 AND CLOSE>7 AND CLOSE<11;

稳赢剑
VAR1:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
VAR5:=CROSS(VAR4,10) AND VAR3<N;
抄底:VAR5;

 

领头羊
白色:=SMA(HIGH,21,2)*1.05,;
黄色:=SMA(LOW,21,2)*0.95;
粉色:=SMA(LOW,5,1);
绿色:=SMA(CLOSE,2,1),;
波段买入:=IF(CROSS(绿色,粉色),白色*1.05,粉色);
领头羊:=IF(CROSS(绿色,白色),白色*1.10,黄色);
领头羊>黄色 OR 波段买入>粉色;

天星踏浪
VARC:=(2*CLOSE+HIGH+LOW)/4;
VARD:=LLV(LOW,34);
VARE:=HHV(HIGH,34);
VARF:=LLV(LOW,13);
VAR10:=HHV(HIGH,13);
VAR11:=EMA((VARC-VARF)/(VAR10-VARD)*100,5);
VAR12:=EMA((VARC-VARD)/(VARE-VARD)*100,8);
金浪:= VAR11;
AA:=EMA(VAR11,7);
海浪:= VAR12;
IF(CROSS(
金浪,AA) AND AA<=25 ,1,0);

黑马绝技
EMA13:=EMA(C,13);
EMA30:=EMA(C,30);
EMA60:=EMA(C,60);
EMA90:=EMA(C,90);
EMA120:=EMA(C,120);
EMA250:=EMA(C,250);
F1:=EMA30-EMA60<130/1000 AND EMA30-EMA90<230/1000 AND EMA30-EMA120<330/1000;
F2:=EMA60-EMA30<130/1000 AND EMA60-EMA90<230/1000 AND EMA60-EMA120<330/1000;
F3:=EMA90-EMA30<130/1000 AND EMA90-EMA60<230/1000 AND EMA90-EMA120<330/1000;
F4:=EMA120-EMA30<130/1000 AND EMA120-EMA60<230/1000 AND EMA120-EMA90<330/1000;
F5:=EMA30-EMA60<100/1000 AND EMA30-EMA90<200/1000;
FF1:=F1 AND F2 AND F3 AND F4 AND CROSS(EMA30,EMA60);
FF2:=F1 AND F2 AND F3 AND F4 AND CROSS(EMA(C,13),EMA30);
FF3:=F5 AND C>EMA250 AND CROSS(EMA30,EMA60);
G1:=EMA60-EMA90<220/1000 AND EMA60-EMA120<320/1000 AND EMA60-EMA250<420/1000;
G2:=EMA90-EMA30<220/1000 AND EMA90-EMA60<320/1000 AND EMA90-EMA250<420/1000;
G3:=EMA120-EMA60<220/1000 AND EMA120-EMA90<320/1000 AND EMA120-EMA250<420/1000;
G4:=EMA250-EMA60<220/1000 AND EMA250-EMA90<320/1000 AND EMA250-EMA120<420/1000;
GG1:=G1 AND G2 AND G3 AND G4 AND CROSS(EMA13,EMA30);
GG2:=G1 AND G2 AND G3 AND G4 AND CROSS(EMA30,EMA60);
FF1 OR FF2 OR FF3 OR GG1 OR GG2;

 

黑马起步
A1:=VOL=HHV(VOL,120);
A2:=CLOSE/OPEN>1.05;
TJ:=A1 AND A2;
TJ AND (REF(BARSLAST(TJ),1)>80 OR BARSSINCE(TJ)=0);

三底背离
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
底背离:B1>0 OR B2>0 OR B3>0;

蓄势待发
V0:=EMA(C,5);
EMA10:=EMA(C,10);
EMA20:=EMA(C,20);
EMA30:=EMA(C,30);
EMA60:=EMA(C,60);
M1:=1000*EMA10/EMA60<=1015 AND 1000*EMA10/EMA60>=975;
M2:=1000*EMA20/EMA60<=1020 AND 1000*EMA20/EMA60>=980;
M3:=1000*EMA30/EMA60<=1015 AND 1000*EMA30/EMA60>=985;
M4:=M1 AND M2 AND M3 AND CROSS(V0,EMA10);
M5:=M1 AND M2 AND M3 AND CROSS(V0,EMA30);
T1:=1000*EMA10/EMA30<=1010 AND 1000*EMA10/EMA30>=990;
T2:=1000*EMA20/EMA30<=1010 AND 1000*EMA20/EMA30>=990;
T3:=T1 AND T2 AND CROSS(V0,EMA10);
T4:=T1 AND T2 AND CROSS(V0,EMA30);
M4 OR M5 OR T3 OR T4;

 

突破指标
{
一是突破盘整;二是突破前高;三是突破平台}
W1:=C=HHV(C,20);
W2:=BARSLAST(W1);
W3:=IF(W2>0,REF(C,W2),REF(C,W2));
W4:=CROSS(C,REF(W3,1));
W4 AND COUNT(W4,5)=1;

四线粘合
V0:=EMA(C,5);
V1:=EMA(C,10);
V2:=EMA(C,15);
V3:=EMA(C,30);
V4:=EMA(C,60);
M1:=1000*V1/V4<=1015 AND 1000*V1/V4>=975;
M2:=1000*V2/V4<=1020 AND 1000*V2/V4>=980;
M3:=1000*V3/V4<=1015 AND 1000*V3/V4>=985;
M4:=M1 AND M2 AND M3 AND CROSS(V0,V1);
M5:=M1 AND M2 AND M3 AND CROSS(V0,V3);
M4 OR M5;

拉升在即
ABV:=MA(SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0)/25000,2);
M1:=EMA(ABV,12);
M2:=EMA(ABV,26);
MTM:=CLOSE-REF(CLOSE,1);
MMS:=((100)*(EMA(EMA(MTM,6),6)))/(EMA(EMA(ABS(MTM),6),6));
MMM:=((100)*(EMA(EMA(MTM,12),12)))/(EMA(EMA(ABS(MTM),12),12));
MML:=((100)*(EMA(EMA(MTM,26),26)))/(EMA(EMA(ABS(MTM),26),26));
A:=((VOL)/(CAPITAL))*(100);
S:=((MA(A,30))/(MA(INDEXA,10)))*(MA(INDEXA,60));
Y:=((MA(A,120))/(MA(INDEXA,10)))*(MA(INDEXA,60));
X:=1;
拉升在即:S<X AND Y<X AND MMS>MML AND ABV>M1 AND CROSS(S,Y);

 

顶天立地
VAR1F:=((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100);
VAR21:=SMA(VAR1F,3,1);
趋势:=SMA(VAR21,3,1);
人气:=SMA(趋势,3,1);
出击:CROSS(趋势,人气) AND (趋势<30);
{
短卖:IF(CROSS(人气,趋势) AND (人气>75),85,100),COLOR008000,LINETHICK2; };

主力进出
ABV:=MA(SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0)/25000,2);
M1:=EMA(ABV,12);
M2:=EMA(ABV,26);
MTM:=CLOSE-REF(CLOSE,1);
MMS:=((100)*(EMA(EMA(MTM,6),6)))/(EMA(EMA(ABS(MTM),6),6));
MMM:=((100)*(EMA(EMA(MTM,12),12)))/(EMA(EMA(ABS(MTM),12),12));
MML:=((100)*(EMA(EMA(MTM,26),26)))/(EMA(EMA(ABS(MTM),26),26));
MTGJ:=C-REF(C,1);
ZLGJ:=100*EMA(EMA(MTGJ,9),9)/EMA(EMA(ABS(MTGJ),9),9);
MAZL:=MA(ZLGJ,5);
主力进出:=MMS>REF(MMS,1) AND ZLGJ>REF(ZLGJ,1) AND CROSS(ABV,M2) AND ABV>REF(ABV,1) AND M1>REF(M1,1) AND M2>REF(M2,1);
主进主轨:=ABV>M2 AND CROSS(ABV,M1) AND CROSS(ZLGJ,MAZL);
主力进出 OR 主进主轨;

一招就够
V1:=EMA(CLOSE,5);
V2:=EMA(EMA(CLOSE,29)*1.01,10);
CROSS(V1,V2);

 

 

 

黑马易找
VAR1:=MA(CLOSE,5);
VAR2:=MA(CLOSE,10);
VAR3:=MA(CLOSE,30);
VAR4:=MA(CLOSE,60);
VAR5:=EMA(COST(85),7);
VAR6:=EMA(COST(15),7);
VAR7:=SUM(CLOSE*VOL*100,4)/SUM(VOL*100,4);
VAR8:=INTPART(VAR7*100)/100;
VAR9:=SUM(CLOSE*VOL*100,7)/SUM(VOL*100,7);
VARA:=INTPART(VAR9*100)/100;
VARB:=SUM(CLOSE*VOL*100,28)/SUM(VOL*100,28);
VARC:=INTPART(VARB*100)/100;
VARD:=EMA(CLOSE,5)-EMA(CLOSE,10);
VARE:=EMA(VARD,9);
VARF:=(-100)*(HHV(CLOSE,5)-CLOSE)/(HHV(CLOSE,5)-LLV(LOW,5))+100;
VAR10:=(-100)*(HHV(CLOSE,10)-CLOSE)/(HHV(CLOSE,10)-LLV(LOW,10))+100;
VAR11:=(-100)*(HHV(CLOSE,20)-CLOSE)/(HHV(CLOSE,20)-LLV(LOW,20))+100;
VAR12:=(-100)*(HHV(CLOSE,30)-CLOSE)/(HHV(CLOSE,30)-LLV(LOW,30))+100;
VAR13:=REF(VARE,1);
VAR14:=VARE;
VAR15:=VAR14-VAR13;
VAR16:=REF(VARD,1);
VAR17:=VARD;
VAR18:=VAR17-VAR16;
VAR19:=OPEN;
VAR1A:=CLOSE;
黑马易找选股: VAR19<=VAR1 AND VAR19<=VAR2 AND VAR19<=VAR3 AND VAR1A>=VAR1 AND VAR1A>=VARC AND VAR15>0 AND VAR18>0;

以逸待劳
VAR1:=COST(10);
VAR2:=REF(CLOSE,7)/MA(REF(CLOSE,7),3)>=1.07 AND REF(CLOSE,7)=HHV(REF(CLOSE,7),3) AND MA(REF(VOL,7),2)/MA(REF(VOL,7),40)>=3 AND MA(REF(VOL,7),2)=HHV(MA(REF(VOL,7),2),3) AND REF(VOL,7)>REF(REF(VOL,7),1) AND REF(CLOSE,7)>REF(REF(CLOSE,7),1);
VAR3:=REF(REF(CLOSE,7),1);
VAR4:=SMA(MAX(REF(CLOSE,7)-VAR3,0),5,1)/SMA(ABS(REF(CLOSE,7)-VAR3),5,1)*100;
VAR5:=COUNT(VAR4<20,20)>=1;
VAR6:=(INDEXC-LLV(INDEXL,89))/(HHV(INDEXH,89)-LLV(INDEXL,89))*100;
VAR7:=SMA(VAR6,8,1);
VAR8:=SMA(VAR7,10,1);
VAR9:=REF(INDEXC,1);
VARA:=SMA(MAX(INDEXC-VAR9,0),6,1)/SMA(ABS(INDEXC-VAR9),6,1)*100;
VARB:=VARA>=75 AND VARA<90 AND VAR7>VAR8 AND BARSLAST(CROSS(VAR7,VAR8))<=21;
VAR2 AND VAR5 AND   VARB;

资金进场
A1:=DYNAINFO(6);
A2:=IF(LOW>A1,0,IF(HIGH<A1,1,(A1-LOW+0.01)/(HIGH-LOW+0.01)));
A3:=VOL/WINNER(LOW);
A4:=REF(HHV(CLOSE,120),1);
A5:=REF(LLV(CLOSE,120),1);
A6:=100*(CLOSE-A5)/(A4-A5);
A7:=A2>0 OR A2=1;
A8:=A7 AND A3/REF(A3,3)>=3 AND A6<80;
A11:=IF(FILTER(A8,3),5,0);
资金进场日:A11>0,8;

 

 

 

  • 10
    点赞
  • 86
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值