poj1007DNA Sorting

19 篇文章 0 订阅
8 篇文章 0 订阅
DNA Sorting
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 81639 Accepted: 32837

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

Source

 
answer:
#include"stdio.h"
#include"stdlib.h"
#include"cstring"
#include"iostream"
#include"algorithm"
using namespace std;
struct node
{
	char str[55];
	int times;
}DNA[105];
/*int cmp(const void *a1,const void *a2)
{
	if((*(node*)a1).times==(*(node*)a2).times)
		return 1;
	else
		return (*(node*)a1).times>(*(node*)a2).times;
}*/
bool cmp(const node &a1,const node &a2)
{
	if(a1.times==a2.times)
		return 1;
	else return a1.times<a2.times;
}
int main(int argc, char* argv[])
{
	int n,m;
	int i,j,k;
	int A,C,G,T;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		for(i=0;i<m;i++)
		{
			DNA[i].times=0;
			A=C=G=T=0;
			scanf("%s",DNA[i].str);
			/*for(j=n-1;j>=0;j--)
			{
				switch(DNA[i].str[j])
				{
				case 'A':
					A++;break;
				case 'C':
					C++;
					DNA[i].times+=A;break;
				case 'G':
					G++; 
					DNA[i].times+=A;
					DNA[i].times+=C;break;
				case 'T':
					DNA[i].times+=A;
					DNA[i].times+=C;
					DNA[i].times+=G;
				}
			}*/
			for(j=0;j<n-1;j++)
			{
				for(k=j+1;k<n;k++)
				{
					if(DNA[i].str[j]>DNA[i].str[k])
					{
						DNA[i].times++;
					}
				}
			}
		}
		sort(DNA,DNA+m,cmp);
		//qsort(DNA,m,sizeof(DNA[0]),cmp);
	
		for(i=0;i<m;i++)
		{
			printf("%s\n",DNA[i].str);
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值