POJ 128——Web Navigation

Web Navigation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 35768 Accepted: 16013

Description

Standard web browsers contain features to move backward and forward among the pages recently visited. One way to implement these features is to use two stacks to keep track of the pages that can be reached by moving backward and forward. In this problem, you are asked to implement this.
The following commands need to be supported: 
BACK: Push the current page on the top of the forward stack. Pop the page from the top of the backward stack, making it the new current page. If the backward stack is empty, the command is ignored. 
FORWARD: Push the current page on the top of the backward stack. Pop the page from the top of the forward stack, making it the new current page. If the forward stack is empty, the command is ignored. 
VISIT : Push the current page on the top of the backward stack, and make the URL specified the new current page. The forward stack is emptied. 
QUIT: Quit the browser. 
Assume that the browser initially loads the web page at the URL http://www.acm.org/

Input

Input is a sequence of commands. The command keywords BACK, FORWARD, VISIT, and QUIT are all in uppercase. URLs have no whitespace and have at most 70 characters. You may assume that no problem instance requires more than 100 elements in each stack at any time. The end of input is indicated by the QUIT command.

Output

For each command other than QUIT, print the URL of the current page after the command is executed if the command is not ignored. Otherwise, print "Ignored". The output for each command should be printed on its own line. No output is produced for the QUIT command.

Sample Input

VISIT http://acm.ashland.edu/
VISIT http://acm.baylor.edu/acmicpc/
BACK
BACK
BACK
FORWARD
VISIT http://www.ibm.com/
BACK
BACK
FORWARD
FORWARD
FORWARD
QUIT

Sample Output

http://acm.ashland.edu/
http://acm.baylor.edu/acmicpc/
http://acm.ashland.edu/
http://www.acm.org/
Ignored
http://acm.ashland.edu/
http://www.ibm.com/
http://acm.ashland.edu/
http://www.acm.org/
http://acm.ashland.edu/
http://www.ibm.com/
Ignored

Source


模拟网页访问,共有四个命令:

BACK(回退),返回之前访问的页面,若不存在则非法

 FORWARD(前进):向前访问回退回来的页面,若不存在则非法

 VISIT(访问新页面), 此命令后是一行网址,输出此网址。

QUIT(退出)结束程序

用二维字符数组存储网址,水题,注意visit命令后要清空向前访问的记录,我的方法是在之后的位置放入-1表示在此截止。


AC代码:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<malloc.h>
int main()
{
	int i;
	char command[72];
	char url[102][72];
	strcpy(url[0],"http://www.acm.org/");
	strcpy(url[1],"-1");
	i=0;
	//freopen("d://in.txt","r",stdin);
	scanf("%s",&command);
	while(strcmp(command,"QUIT")!=0){
		if(strcmp(command,"VISIT")==0){
			scanf("%s",&url[++i]);
			strcpy(url[i+1],"-1");
			printf("%s\n",url[i]);
		}
		else if(strcmp(command,"BACK")==0){
			if(i-1<0){
				printf("Ignored\n");
			}
			else{
				i--;
				printf("%s\n",url[i]);
			}
		}
		else if(strcmp(command,"FORWARD")==0){
			if(strcmp(url[i+1],"-1")==0){
				printf("Ignored\n");
			}
			else{
				i++;
				printf("%s\n",url[i]);
			}
		}
		scanf("%s",&command);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值