poj-1028 Web Navigation

Web Navigation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 26871 Accepted: 12005

Description

Standard web browsers contain features to move backward and forward among the pages recently visited. One way to implement these features is to use two stacks to keep track of the pages that can be reached by moving backward and forward. In this problem, you are asked to implement this. 
The following commands need to be supported: 
BACK: Push the current page on the top of the forward stack. Pop the page from the top of the backward stack, making it the new current page. If the backward stack is empty, the command is ignored. 
FORWARD: Push the current page on the top of the backward stack. Pop the page from the top of the forward stack, making it the new current page. If the forward stack is empty, the command is ignored. 
VISIT : Push the current page on the top of the backward stack, and make the URL specified the new current page. The forward stack is emptied. 
QUIT: Quit the browser. 
Assume that the browser initially loads the web page at the URL http://www.acm.org/

Input

Input is a sequence of commands. The command keywords BACK, FORWARD, VISIT, and QUIT are all in uppercase. URLs have no whitespace and have at most 70 characters. You may assume that no problem instance requires more than 100 elements in each stack at any time. The end of input is indicated by the QUIT command.

Output

For each command other than QUIT, print the URL of the current page after the command is executed if the command is not ignored. Otherwise, print "Ignored". The output for each command should be printed on its own line. No output is produced for the QUIT command.

Sample Input

VISIT http://acm.ashland.edu/
VISIT http://acm.baylor.edu/acmicpc/
BACK
BACK
BACK
FORWARD
VISIT http://www.ibm.com/
BACK
BACK
FORWARD
FORWARD
FORWARD
QUIT

Sample Output

http://acm.ashland.edu/
http://acm.baylor.edu/acmicpc/
http://acm.ashland.edu/
http://www.acm.org/
Ignored
http://acm.ashland.edu/
http://www.ibm.com/
http://acm.ashland.edu/
http://www.acm.org/
http://acm.ashland.edu/
http://www.ibm.com/
Ignored

Source

题目大意:就是模拟现在浏览器的前进后退还有访问网站的过程。有两种方法,思路都差不多,都是用堆栈的思路。

第一种方法用数组来模拟堆栈,较容易理解。此方法0ms。

#include<iostream>
#include<string>
using namespace std;
int main()
{
	int top,pop,max;
	top=max=0;
	string s[101],m;
	s[top]="http://www.acm.org/";
	while(cin>>m)
	{
		if(m=="QUIT")
			break;
		if(m=="VISIT")
		{
			cin>>m;
			s[++top]=m;
			cout<<s[top]<<endl;
			max=top;
		}
		else
			if(m=="BACK")
			{
				if(top!=0)
				{
					cout<<s[--top]<<endl;
				}
					else cout<<"Ignored"<<endl;
			}
			else
			{
				if(top<max)
				{
					cout<<s[++top]<<endl;
				}
					else cout<<"Ignored"<<endl;

			}

	}
	return 0;
}

第二种方法是用堆栈来做,建立两个堆栈,其中的一个来存储以前的网站,如果有前进或者后退的就从这个堆栈中去找。

这个速度比较慢,但是可以更好的理解栈的用法

#include<iostream>
#include<string>
#include<stack>
using namespace std;
int main()
{
	stack<string>a,b;
	string s;
		string st;
	s="http://www.acm.org/";
	a.push(s);
	while(cin>>s)
	{
		if(s=="VISIT")
		{
			string st;
			cin>>st;
			a.push(st);
			cout<<a.top()<<endl;
			while(!b.empty())//是用来释放b堆栈的
			{
				b.pop();
			}
		}
		else
			if(s=="BACK")
			{
				st=a.top();
				a.pop();
				if(a.empty())
				{
					a.push(st);
					cout<<"Ignored"<<endl;
				}
				else
				{
					b.push(st);
					cout<<a.top()<<endl;
				}
			}
			else
				if(s=="FORWARD")
				{
					if(b.empty())
					{
						cout<<"Ignored"<<endl;
					}
					else
					{
						a.push(b.top());
						b.pop();
						cout<<a.top()<<endl;
					}

				}
				else
					if(s=="QUIT")
						break;
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值