hdu_5724 Chess(SG函数)

Chess

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/65536 K (Java/Others)
Problem Description

Alice and Bob are playing a special chess game on an n × 20 chessboard. There are several chesses on the chessboard. They can move one chess in one turn. If there are no other chesses on the right adjacent block of the moved chess, move the chess to its right adjacent block. Otherwise, skip over these chesses and move to the right adjacent block of them. Two chesses can’t be placed at one block and no chess can be placed out of the chessboard. When someone can’t move any chess during his/her turn, he/she will lose the game. Alice always take the first turn. Both Alice and Bob will play the game with the best strategy. Alice wants to know if she can win the game.

Input

Multiple test cases.

The first line contains an integer T(T≤100), indicates the number of test cases.

For each test case, the first line contains a single integer n(n≤1000), the number of lines of chessboard.

Then n lines, the first integer of ith line is m(m≤20), indicates the number of chesses on the ith line of the chessboard. Then m integers pj(1≤pj≤20) followed, the position of each chess.

Output

For each test case, output one line of “YES” if Alice can win the game, “NO” otherwise.

Sample Input

2
1
2 19 20
2
1 19
1 18

Sample Output

NO
YES

题意

有大小为n*20的棋盘,有一些棋子在棋盘上,A,B两人轮流对棋盘进行操作,每次操作可以选择一个棋子移动,如果它右边相邻的格子为空,则移动至右边相邻的格子,若有其他棋子,则可以直接跳过其他棋子,移动至他们右边的格子。A先手,是否存在必胜策略。

题解:

因为每次操作只能将棋子右移,所以可以将n行分开来看,单独考虑每一行。因为每一行的大小为20,最多有2^20种状态,而且每种状态最多可以有可以向20个其他的状态转移,所以可以先求出每种状态的SG函数。
对于n行,每一行对应一个SG值,每个SG值可以转换到小于它的非负整数,其实相当于nim博弈,对n个SG值异或即可。

SG值怎么求?
对于必败态,SG值为0;其余状态的SG值则为mex{x|x为下一步转移到的状态的SG值}。mex为不属于集合的最小非负整数。如 m e x { 0 , 1 , 3 } = 2 mex\{0,1,3\} = 2 mex{0,1,3}=2, m e x { 2 , 3 } = 0 mex\{2,3\} = 0 mex{2,3}=0

#include<cstdio>
#include<iostream>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#include<ctype.h>
#include<cstring>
#include<set>
#include<queue>
#include<stack>
#include<iterator>
#define dbg(x) cout<<#x<<" = "<<x<<endl;
#define INF 0x3f3f3f3f
#define eps 1e-6
 
using namespace std;
typedef long long LL;   
typedef pair<int, int> P;
const int maxn = 1<<21;
const int mod = 10007;
int a[30], b[30], sg[maxn];
void init();

int main()
{
    init();
    for(int i=0;i<=21;i++)
        a[i] = (1<<i);
    int t, n, m, sig, i, j, x, up;
    scanf("%d", &t);
    while(t--)
    {
        sig = 0, up = 0;
        scanf("%d", &n);
        while(n--)
        {
            x = 0;
            scanf("%d", &m);
            for(i=0;i<m;i++)
            {
                scanf("%d", &j);
                x += a[20-j];
            }
            sig ^= sg[x];
        }
        if(sig)printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}
//预处理求每种状态的SG值
void init()
{
    memset(sg, 0, sizeof(sg));
    int i, j, k, x, top, sum = 1<<20;
    for(i=0;i<=23;i++)
        a[i] = 1<<i;
    for(i=2;i<sum;i++)
    {
        memset(b, 0, sizeof(b));
        for(j=19;j>=0;j--)
            if(i & (1<<j))
            {
                for(k=j-1;k>=0;k--)
                    if((i & (1<<k)) == 0)break;
                if(k<0)break;
                x = i - (1<<j) + (1<<k);
                b[sg[x]] = 1;
            }
        for(j=0;;j++)
            if(b[j] == 0){
                sg[i] = j;break;
            }
    }
        
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值