POJ_2983 Is the Information Reliable?(差分约束)

Is the Information Reliable?

Time Limit: 3000MS
Memory Limit: 131072K
Problem Description

The galaxy war between the Empire Draco and the Commonwealth of Zibu broke out 3 years ago. Draco established a line of defense called Grot. Grot is a straight line with N defense stations. Because of the cooperation of the stations, Zibu’s Marine Glory cannot march any further but stay outside the line.

A mystery Information Group X benefits form selling information to both sides of the war. Today you the administrator of Zibu’s Intelligence Department got a piece of information about Grot’s defense stations’ arrangement from Information Group X. Your task is to determine whether the information is reliable.

The information consists of M tips. Each tip is either precise or vague.

Precise tip is in the form of P A B X, means defense station A is X light-years north of defense station B.

Vague tip is in the form of V A B, means defense station A is in the north of defense station B, at least 1 light-year, but the precise distance is unknown.

Input

There are several test cases in the input. Each test case starts with two integers N (0 < N ≤ 1000) and M (1 ≤ M ≤ 100000).The next M line each describe a tip, either in precise form or vague form.

Output

Output one line for each test case in the input. Output “Reliable” if It is possible to arrange N defense stations satisfying all the M tips, otherwise output “Unreliable”.

Sample Input

3 4
P 1 2 1
P 2 3 1
V 1 3
P 1 3 1
5 5
V 1 2
V 2 3
V 3 4
V 4 5
V 3 5

Sample Output

Unreliable
Reliable

题意

两国正在交战,其中一个国家在一条南北向的直线上建立了n个防御站。另一个国家通过情报组织获取了一些关于这条防线的信息。信息分为两种,一种是详细信息,格式为P A B X,代表防御战A在防御战B的北x米处;一种是粗略信息,格式为V A B,代表防御战A在防御战B的北方,至少1米。
给出情报集,判断该情报集是否存在相互冲突的部分。

题解:

差分约束:
P A B X: A − B = X A-B=X AB=X,可以将其看做 A − B ≥ X A-B\ge X ABX A − B ≤ X A-B\le X ABX,等价于 A − B ≥ X A-B\ge X ABX B − A ≥ − X B-A \ge -X BAX。建边 B − > A B->A B>A边权为 X X X A − > B A->B A>B边权为 − X -X X
V A B: A − B ≥ 1 A-B\ge 1 AB1。建边, B − > A B->A B>A边权为 1 1 1

建图后,判断图中是否存在正环,若存在,则无解,否则存在合理解。

#include<cstdio>
#include<iostream>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<map>
#include<vector>
#include<queue>
#include<iterator>
#include<string>
#define dbg(x) cout<<#x<<" = "<<x<<endl;
#define INF 0x3f3f3f3f
#define LLINF 0x3f3f3f3f3f3f3f3f
#define eps 1e-6

using namespace std;
typedef long long LL;
typedef pair<LL, int> P;
const int maxn = 2020;
const int mod = 998244353;
int dis[maxn], vis[maxn], cnt[maxn];
int tot, hd[maxn], nex[maxn*120], to[maxn*120], w[maxn*120];
bool spfa(int n);
void add(int u, int v, int p);

int main()
{
    int n, m, i, j, k, L, R;
    char ch;
    while(scanf("%d %d", &n, &m)!=EOF)
    {
        tot = 0;
        memset(hd, -1, sizeof(hd));
        while(m--){
            scanf(" %c", &ch);
            if(ch == 'P'){
                scanf("%d %d %d", &i, &j, &k);
                add(j, i, k);
                add(i, j, -k);
            }else{
                scanf("%d %d", &i, &j);
                add(j, i, 1);
            }
        }
        for(i=1;i<=n;i++)add(0, i, 0);
        if(spfa(n))puts("Unreliable");
        else puts("Reliable");
    }
    return 0;
}

void add(int u, int v, int p)
{
    to[tot] = v;
    w[tot]= p;
    nex[tot] = hd[u];
    hd[u] = tot++;
}

bool spfa(int n)
{
    for(int i=0;i<=n;i++)
        dis[i] = -INF, cnt[i] = vis[i] = 0;
    queue<int> que;
    que.push(0);
    dis[0] = 0, vis[0] = 1;
    while(que.size())
    {
        int u = que.front();que.pop();
        vis[u] = 0;
        for(int i=hd[u];i!=-1;i=nex[i]){
            if(dis[to[i]] < dis[u]+w[i]){
                dis[to[i]] = dis[u]+w[i];
                if(!vis[to[i]] && cnt[to[i]]<=n){
                    cnt[to[i]]++, vis[to[i]] = 1;
                    if(cnt[to[i]]>n)return true;
                    que.push(to[i]);
                }
            }
        }
    }
    return false;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值