ZOJ1586 QS Network

12 篇文章 0 订阅
12 篇文章 0 订阅




QS Network

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Sunny Cup 2003 - Preliminary Round

April 20th, 12:00 - 17:00

Problem E: QS Network


In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS's have received the message.

A sample is shown below:


A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS's favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.


Input

The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS's favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.


Output

for each data set,output the minimum cost in a line. NO extra empty lines needed.


Sample Input

1
3
10 20 30
0 100 200
100 0 300
200 300 0


Sample Output

370





Prim算法求最小生成树,没有什么要特别注意的


#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<map>
#include<cstring>
using namespace std;
const int inf=10000000;
int qs[1200];//每个qs用的适配器价格
int mp[1200][1200];//邻接矩阵
int T,n; 
int lowc[1200];

void prim(){
	memset(lowc,0,sizeof(lowc));
	int i,j;
	int sum=0;
	lowc[1]=-1;
	for(i=2;i<=n;i++)lowc[i]=mp[1][i];//初始化距离数组为到各点距离 
	for(i=2;i<=n;i++){
		int mini=inf;
		int k;
		for(j=1;j<=n;j++){
			if(lowc[j]!=-1 && lowc[j]<mini){//寻找未连接的点中距离最近的 
				mini=lowc[j];
				k=j;
			}
		}
		sum+=mini;
		lowc[k]=-1;
		for(j=1;j<=n;j++){
			if(lowc[j]>mp[k][j])lowc[j]=mp[k][j];
		}
	}
	printf("%d\n",sum);
}
int main(){
	scanf("%d",&T);
	while(T--){
		memset(mp,0,sizeof(0));
		scanf("%d",&n);
		int i,j;
		for(i=1;i<=n;i++)scanf("%d",&qs[i]);
		for(i=1;i<=n;i++)
		  for(j=1;j<=n;j++){
		  	scanf("%d",&mp[i][j]);
		  	if(i==j)mp[i][j]=inf;
		  	else mp[i][j]+=qs[i]+qs[j];//边价格+适配器价格 
		  }
		prim();
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值