2019-02-24-Graph Coloring-POJ1419-图着色问题-最大独立集-最大团问题

2 篇文章 0 订阅
1 篇文章 0 订阅

POJ-1419-Graph Coloring

Problem Description

You are to write a program that tries to find an optimal coloring for a given graph. Colors are applied to the nodes of the graph and the only available colors are black and white. The coloring of the graph is called optimal if a maximum of nodes is black. The coloring is restricted by the rule that no two connected nodes may be black.


Figure 1: An optimal graph with three black nodes


Input

The graph is given as a set of nodes denoted by numbers 1...n, n <= 100, and a set of undirected edges denoted by pairs of node numbers (n1, n2), n1 != n2. The input file contains m graphs. The number m is given on the first line. The first line of each graph contains n and k, the number of nodes and the number of edges, respectively. The following k lines contain the edges given by a pair of node numbers, which are separated by a space.

Output

The output should consists of 2m lines, two lines for each graph found in the input file. The first line of should contain the maximum number of nodes that can be colored black in the graph. The second line should contain one possible optimal coloring. It is given by the list of black nodes, separated by a blank.


Sample Input

1

6 8

1 2

1 3

2 4

2 5

3 4

3 6

4 6

5 6

Sample Output

3

1 4 5

题目简述

对于给定的图G(V,E),用两种颜色(黑,白)进行着色,找出符合条件黑色尽可能多的图,并给出其中一种方案

条件:对于任意两个相邻的点,不能同时为黑色。

分析:题意即找出最大的集合,其中任意两点都不相邻(最大独立集,独立集),即找到补图的最大团。

条目检索:最大独立集独立集补图最大团问题

输入输出

输入:无难点

输出:要求记录最大团集合(不要求排序)

使用模板-最大团(dfs)模板

//最大团模板
//dfs+dp+剪枝
struct MAX_CLIQUE{
    static const int N=110;
    bool G[N][N];    //G(V,E)记录数组
    int n,Max[N],Alt[N][N],ans;
    //Max[i]为集合{i,i+1,...,n}中最大团的数目,用于剪枝
    //Alt[i][j],第i次dfs中当前可选集合的第j个元素
    //ans,答案记录
    bool DFS(int cur,int tot){
        if(!cur){
            if(tot>ans){
				ans=tot;
				return 1;
			}
            return 0;
        }
        for(int i=0;i<cur;i++){
			int u=Alt[tot][i],nxt=0;
            if(cur-i+tot<=ans)return 0;
            if(Max[u]+tot<=ans)return 0;
            for(int j=i+1;j<cur;j++)
                if(G[u][Alt[tot][j]])Alt[tot+1][nxt++]=Alt[tot][j];
            if(DFS(nxt,tot+1))return 1;
        }
        return 0;
    }
    int MaxClique(){
        ans=0,memset(Max,0,sizeof(Max));
        for(int i=n-1;i>=0;i--){
            int cur=0;
            for(int j=i+1;j<n;j++)
                if(G[i][j])Alt[1][cur++]=j;
            DFS(cur,1);
            Max[i]=ans;
        }
        return ans;
    }
}Group;

AC代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct MAX_CLIQUE{
    static const int N=110;
    bool G[N][N];
    int n,Max[N],Alt[N][N],ans;
    int y[N];
    int x[N];
    int *path,*res;
    bool DFS(int cur,int tot){
        if(!cur){
            if(tot>ans){
				ans=tot;
				swap(path,res);
				return 1;
			}
            return 0;
        }
        for(int i=0;i<cur;i++){
			int u=Alt[tot][i],nxt=0;
            if(cur-i+tot<=ans)return 0;
            if(Max[u]+tot<=ans)return 0;
            path[tot+1]=u;
            for(int j=i+1;j<cur;j++)
                if(G[u][Alt[tot][j]])Alt[tot+1][nxt++]=Alt[tot][j];
            if(DFS(nxt,tot+1))return 1;
        }
        return 0;
    }
    int MaxClique(){
        ans=0,memset(Max,0,sizeof(Max));
        path=x,res=y;
        for(int i=n-1;i>=0;i--){
            int cur=0;
            for(int j=i+1;j<n;j++)
                if(G[i][j])Alt[1][cur++]=j;
            path[1]=i;
            DFS(cur,1);
            Max[i]=ans;
        }
        return ans;
    }
}Group;    //模板
int main(){
	int m;
	scanf("%d",&m);
	while(m--){
		int k;
		int a,b;

		scanf("%d%d",&Group.n,&k);
		memset(Group.G,true,sizeof(Group.G));
		while(k--){
			scanf("%d%d",&a,&b);
			Group.G[a-1][b-1]=Group.G[b-1][a-1]=0;
		}

		int x=Group.MaxClique();

		printf("%d\n",x);
		for(int i=1;i<=x;i++){
			printf("%d ",Group.res[i]+1);
		}
		printf("\n");
	}
	return 0;
}

参考链接

https://www.cnblogs.com/jianrenfang/p/5955185.html

http://www.cnblogs.com/zhj5chengfeng/archive/2013/07/29/3224092.html

  • 0
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值