maven小记

今天看服务器上报错,说jar包加载过多,导致内存不够。

本来对maven 没太在意,今天借此整理下maven里不用的jar包,发现有很多maven相关包。


<dependency>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-resources-plugin</artifactId>
            <version>2.4.3</version>
 </dependency>


于是用maven dependency:tree


[INFO] +- org.apache.maven.plugins:maven-resources-plugin:jar:2.4.3:compile
[INFO] |  +- org.apache.maven:maven-plugin-api:jar:2.0.6:compile
[INFO] |  +- org.apache.maven:maven-project:jar:2.0.6:compile
[INFO] |  |  +- org.apache.maven:maven-profile:jar:2.0.6:compile
[INFO] |  |  +- org.apache.maven:maven-artifact-manager:jar:2.0.6:compile
[INFO] |  |  \- org.apache.maven:maven-plugin-registry:jar:2.0.6:compile
[INFO] |  +- org.apache.maven:maven-core:jar:2.0.6:compile
[INFO] |  |  +- org.apache.maven.wagon:wagon-file:jar:1.0-beta-2:runtime
[INFO] |  |  +- org.apache.maven:maven-plugin-parameter-documenter:jar:2.0.6:com
pile
[INFO] |  |  +- org.apache.maven.wagon:wagon-http-lightweight:jar:1.0-beta-2:run
time
[INFO] |  |  |  +- org.apache.maven.wagon:wagon-http-shared:jar:1.0-beta-2:runti
me
[INFO] |  |  |  |  \- jtidy:jtidy:jar:4aug2000r7-dev:runtime
[INFO] |  |  |  \- xml-apis:xml-apis:jar:1.0.b2:runtime
[INFO] |  |  +- org.apache.maven.reporting:maven-reporting-api:jar:2.0.6:compile

[INFO] |  |  |  \- org.apache.maven.doxia:doxia-sink-api:jar:1.0-alpha-7:compile

[INFO] |  |  +- org.apache.maven.wagon:wagon-provider-api:jar:1.0-beta-2:compile

[INFO] |  |  +- org.apache.maven:maven-repository-metadata:jar:2.0.6:compile
[INFO] |  |  +- org.apache.maven:maven-error-diagnostics:jar:2.0.6:compile
[INFO] |  |  +- commons-cli:commons-cli:jar:1.0:compile
[INFO] |  |  +- org.apache.maven.wagon:wagon-ssh-external:jar:1.0-beta-2:runtime

[INFO] |  |  |  \- org.apache.maven.wagon:wagon-ssh-common:jar:1.0-beta-2:runtim
e
[INFO] |  |  +- org.apache.maven:maven-plugin-descriptor:jar:2.0.6:compile
[INFO] |  |  +- org.codehaus.plexus:plexus-interactivity-api:jar:1.0-alpha-4:com
pile
[INFO] |  |  +- org.apache.maven.wagon:wagon-ssh:jar:1.0-beta-2:runtime
[INFO] |  |  |  \- com.jcraft:jsch:jar:0.1.27:runtime
[INFO] |  |  \- classworlds:classworlds:jar:1.1:compile
[INFO] |  +- org.apache.maven:maven-artifact:jar:2.0.6:compile
[INFO] |  +- org.apache.maven:maven-settings:jar:2.0.6:compile
[INFO] |  +- org.apache.maven:maven-model:jar:2.0.6:compile
[INFO] |  +- org.apache.maven:maven-monitor:jar:2.0.6:compile
[INFO] |  +- org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable
-1:compile
[INFO] |  +- org.codehaus.plexus:plexus-utils:jar:2.0.5:compile
[INFO] |  +- org.apache.maven.shared:maven-filtering:jar:1.0-beta-4:compile
[INFO] |  |  \- org.sonatype.plexus:plexus-build-api:jar:0.0.4:compile
[INFO] |  \- org.codehaus.plexus:plexus-interpolation:jar:1.13:compile


卧槽,一个jar包引进了20多个jar包依赖!!!!还对我没啥用!!!

赶紧删了


发布了34 篇原创文章 · 获赞 152 · 访问量 51万+
展开阅读全文

eclipse创建maven工程时报错

07-15

使用的是官方的Eclipse中自带的m2e插件,创建maven项目时就弹出个错误 ![图片说明](https://img-ask.csdn.net/upload/201507/15/1436949464_186734.png) 在pom.xml文件那会显示个红X,提示如下: Multiple annotations found at this line: - Plugin execution not covered by lifecycle configuration: org.apache.maven.plugins:maven-compiler-plugin:3.1:testCompile (execution: default-testCompile, phase: test- compile) - Execution default-resources of goal org.apache.maven.plugins:maven-resources-plugin:2.6:resources failed: Plugin org.apache.maven.plugins:maven-resources-plugin:2.6 or one of its dependencies could not be resolved: The following artifacts could not be resolved: org.apache.maven:maven-plugin-api:jar:2.0.6, org.apache.maven:maven- project:jar:2.0.6, org.apache.maven:maven-profile:jar:2.0.6, org.apache.maven:maven-artifact-manager:jar:2.0.6, org.apache.maven:maven-plugin-registry:jar:2.0.6, org.apache.maven:maven-core:jar:2.0.6, org.apache.maven:maven-plugin-parameter-documenter:jar:2.0.6, org.apache.maven:maven-repository-metadata:jar:2.0.6, org.apache.maven:maven-error-diagnostics:jar:2.0.6, org.apache.maven:maven-plugin-descriptor:jar:2.0.6, org.apache.maven:maven-artifact:jar:2.0.6, org.apache.maven:maven- settings:jar:2.0.6, org.apache.maven:maven-model:jar:2.0.6, org.apache.maven:maven-monitor:jar:2.0.6, org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1: Failure to transfer org.apache.maven:maven-plugin-api:jar:2.0.6 from https://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced. Original error: Could not transfer artifact org.apache.maven:maven-plugin-api:jar:2.0.6 from/to central (https://repo.maven.apache.org/maven2): The operation was cancelled. (org.apache.maven.plugins:maven-resources-plugin:2.6:resources:default-resources:process-resources) org.apache.maven.plugin.PluginExecutionException: Execution default-resources of goal org.apache.maven.plugins:maven-resources-plugin:2.6:resources failed: Plugin org.apache.maven.plugins:maven-resources-plugin:2.6 or one of its dependencies could not be resolved: The following artifacts could not be resolved: org.apache.maven:maven- plugin-api:jar:2.0.6, org.apache.maven:maven-project:jar:2.0.6, org.apache.maven:maven-profile:jar:2.0.6, org.apache.maven:maven-artifact-manager:jar:2.0.6, org.apache.maven:maven-plugin-registry:jar:2.0.6, org.apache.maven:maven-core:jar:2.0.6, org.apache.maven:maven-plugin-parameter-documenter:jar:2.0.6, org.apache.maven:maven-repository-metadata:jar:2.0.6, org.apache.maven:maven-error-diagnostics:jar:2.0.6, org.apache.maven:maven-plugin-descriptor:jar:2.0.6, org.apache.maven:maven-artifact:jar:2.0.6, org.apache.maven:maven-settings:jar:2.0.6, org.apache.maven:maven-model:jar:2.0.6, org.apache.maven:maven-monitor:jar:2.0.6, org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1: Failure to transfer org.apache.maven:maven-plugin-api:jar:2.0.6 from https://repo.maven.apache.org/ maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced. Original error: Could not transfer artifact org.apache.maven:maven-plugin-api:jar:2.0.6 from/to central (https://repo.maven.apache.org/maven2): The operation was cancelled. at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:106) at org.eclipse.m2e.core.internal.embedder.MavenImpl.execute(MavenImpl.java:331) at org.eclipse.m2e.core.internal.embedder.MavenImpl$11.call(MavenImpl.java:1362) at org.eclipse.m2e.core.internal.embedder.MavenImpl$11.call(MavenImpl.java:1) at org.eclipse.m2e.core.internal.embedder.MavenExecutionContext.executeBare(MavenExecutionContext.java:176) at org.eclipse.m2e.core.internal.embedder.MavenExecutionContext.execute(MavenExecutionContext.java:112) at org.eclipse.m2e.core.internal.embedder.MavenImpl.execute(MavenImpl.java:1360) at org.eclipse.m2e.core.project.configurator.MojoExecutionBuildParticipant.build(MojoExecutionBuildParticipant.java:52) at org.eclipse.m2e.core.internal.builder.MavenBuilderImpl.build(MavenBuilderImpl.java:137) at org.eclipse.m2e.core.internal.builder.MavenBuilder$1.method(MavenBuilder.java:172) at org.eclipse.m2e.core.internal.builder.MavenBuilder$1.method(MavenBuilder.java:1) at org.eclipse.m2e.core.internal.builder.MavenBuilder$BuildMethod$1$1.call(MavenBuilder.java: 115) at org.eclipse.m2e.core.internal.embedder.MavenExecutionContext.executeBare(MavenExecutionContext.java:176) at org.eclipse.m2e.core.internal.embedder.MavenExecutionContext.execute(MavenExecutionContext.java:112) at org.eclipse.m2e.core.internal.builder.MavenBuilder$BuildMethod $1.call(MavenBuilder.java:105) at org.eclipse.m2e.core.internal.embedder.MavenExecutionContext.executeBare(MavenExecutionContext.java:176) at org.eclipse.m2e.core.internal.embedder.MavenExecutionContext.execute(MavenExecutionContext.java:151) at org.eclipse.m2e.core.internal.embedder.MavenExecutionContext.execute(MavenExecutionContext.java:99) at org.eclipse.m2e.core.internal.builder.MavenBuilder $BuildMethod.execute(MavenBuilder.java:86) at org.eclipse.m2e.core.internal.builder.MavenBuilder.build(MavenBuilder.java:200) at org.eclipse.core.internal.events.BuildManager $2.run(BuildManager.java:734) at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42) at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:205) at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:245) at org.eclipse.core.internal.events.BuildManager$1.run(BuildManager.java:300) at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42) at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:303) at org.eclipse.core.internal.events.BuildManager.basicBuildLoop(BuildManager.java:359) at org.eclipse.core.internal.events.BuildManager.build(BuildManager.java:382) at org.eclipse.core.internal.events.AutoBuildJob.doBuild(AutoBuildJob.java:144) at org.eclipse.core.internal.events.AutoBuildJob.run(AutoBuildJob.java:235) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55) Caused by: org.apache.maven.plugin.PluginResolutionException: Plugin org.apache.maven.plugins:maven-resources- plugin:2.6 or one of its dependencies could not be resolved: The following artifacts could not be resolved: org.apache.maven:maven-plugin-api:jar:2.0.6, org.apache.maven:maven- project:jar:2.0.6, org.apache.maven:maven-profile:jar:2.0.6, 请问如何解决?谢谢 ----- 本机安装的maven是3.2.2 eclipse是4.5 m2e是1.2 ----- 最后也不知道什么原因,重新下了eclipse就没有问题了 问答

怎么查看maven的pom.xml是否成功下载了所需jar包

06-23

## 如题,pom.xml动不动就要报错,不知道是不是因为没有成功下载jar的原因? ![图片说明](https://img-ask.csdn.net/upload/201606/23/1466666764_888875.jpg) Multiple annotations found at this line: - Missing artifact org.apache.maven:maven-artifact:jar:2.0.6:compile - Missing artifact org.apache.maven.shared:maven-filtering:jar:1.0-beta-4:compile - Missing artifact org.apache.maven:maven-profile:jar:2.0.6:compile - Missing artifact org.apache.maven.reporting:maven-reporting-api:jar: 2.0.6:compile - Missing artifact org.apache.maven:maven-plugin-descriptor:jar:2.0.6:compile - Missing artifact org.apache.maven.wagon:wagon-ssh:jar:1.0-beta-2:runtime - Missing artifact org.apache.maven.wagon:wagon-ssh-external:jar:1.0- beta-2:runtime - Missing artifact org.apache.maven:maven-artifact-manager:jar:2.0.6:compile - Missing artifact org.apache.maven:maven-plugin-registry:jar:2.0.6:compile - Missing artifact org.apache.maven:maven-project:jar:2.0.6:compile - Missing artifact org.apache.maven:maven-plugin-api:jar:2.0.6:compile - Missing artifact org.codehaus.plexus:plexus-utils:jar:2.0.5:compile - Missing artifact com.jcraft:jsch:jar:0.1.27:runtime - Missing artifact commons-cli:commons-cli:jar:1.0:compile - Missing artifact org.apache.maven.wagon:wagon-ssh-common:jar:1.0- beta-2:runtime - Missing artifact org.codehaus.plexus:plexus-interactivity-api:jar:1.0- alpha-4:compile - Missing artifact org.wisdom-framework:mysql-connector-java:jar:5.1.34_1:compile - Failed to read artifact descriptor for org.wisdom-framework:abstract-jdbc- driver:jar:0.5 - Missing artifact org.apache.maven.wagon:wagon-file:jar:1.0-beta-2:runtime - Missing artifact org.sonatype.plexus:plexus-build-api:jar:0.0.4:compile - Missing artifact classworlds:classworlds:jar:1.1:compile - Missing artifact org.apache.maven.plugins:maven-resources-plugin:jar: 2.4.3:compile - Missing artifact org.apache.felix:org.apache.felix.ipojo.annotations:jar: 1.12.1:compile - Missing artifact org.codehaus.plexus:plexus-interpolation:jar:1.13:compile - Missing artifact org.apache.maven.wagon:wagon-provider-api:jar:1.0- beta-2:compile - Missing artifact org.apache.maven:maven-monitor:jar:2.0.6:compile - Missing artifact xml-apis:xml-apis:jar:1.0.b2:runtime - Missing artifact org.apache.maven.wagon:wagon-http-shared:jar:1.0- beta-2:runtime - Missing artifact jtidy:jtidy:jar:4aug2000r7-dev:runtime - Missing artifact org.apache.maven:maven-core:jar:2.0.6:compile - Missing artifact org.apache.maven:maven-settings:jar:2.0.6:compile - Missing artifact org.apache.maven:maven-model:jar:2.0.6:compile - Missing artifact org.apache.maven.doxia:doxia-sink-api:jar:1.0-alpha-7:compile - Missing artifact org.apache.maven.wagon:wagon-http-lightweight:jar:1.0- beta-2:runtime - Missing artifact org.apache.maven:maven-repository-metadata:jar:2.0.6:compile - Missing artifact org.apache.maven:maven-error-diagnostics:jar:2.0.6:compile - Missing artifact org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9- stable-1:compile - Missing artifact junit:junit:jar:3.8.1:test - Missing artifact org.apache.maven:maven-plugin-parameter-documenter:jar: 2.0.6:compile 问答

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 大白 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览