04-树5 Root of AVL Tree

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer NNN (≤20\le 2020) which is the total number of keys to be inserted. Then NNN distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

主要是调整平衡二叉树,LL,RR,LR,RL.....
#include <stdio.h>
#include <stdlib.h>
#define ElementType int
#define Max(a,b) ((a)>(b)?(a):(b))
typedef struct AVLTreeNode{
    ElementType Data;
    struct AVLTreeNode *Left;
    struct AVLTreeNode *Right;
    int Height;
} *AVLTree;


int 
GetHeight(AVLTree T)
{
    if(!T) 
        return 0;
    else
        return T->Height;
}

AVLTree
SingleLeftRotation(AVLTree A)
{
    AVLTree B=A->Left;
    A->Left=B->Right;
    B->Right=A;
    A->Height=Max(GetHeight(A->Left),GetHeight(A->Right))+1;
    B->Height=Max(GetHeight(B->Left),A->Height)+1;
    
    return B;
}

AVLTree
SingleRightRotation(AVLTree A)
{
    AVLTree B=A->Right;
    A->Right=B->Left;
    B->Left=A;
    A->Height=Max(GetHeight(A->Left),GetHeight(A->Right))+1;
    B->Height=Max(GetHeight(B->Right),A->Height)+1;
    
    return B;
}

AVLTree
DoubleLeftRightRotation(AVLTree A)
{
    A->Left=SingleRightRotation(A->Left);
    return SingleLeftRotation(A);
}


AVLTree
DoubleRightLeftRotation(AVLTree A)
{
    A->Right=SingleLeftRotation(A->Right);
    return SingleRightRotation(A);
}

AVLTree 
AVL_Insertion(ElementType X, AVLTree T)
{
    if(!T){
        T=(AVLTree)malloc(sizeof(struct AVLTreeNode));
        T->Data=X;
        T->Height=0;
        T->Left=T->Right=NULL;
    }else if(X<T->Data){
        T->Left=AVL_Insertion(X,T->Left);
        if(GetHeight(T->Left)-GetHeight(T->Right)==2)	//判断左右两边的树平衡不
            if(X<T->Left->Data)
                T=SingleLeftRotation(T);	//LL旋转
            else
                T=DoubleLeftRightRotation(T);	//LR旋转
    }else if(X>T->Data){
        T->Right=AVL_Insertion(X,T->Right);
        if(GetHeight(T->Left)-GetHeight(T->Right)==-2)
            if(X>T->Right->Data)
                T=SingleRightRotation(T);	//RR旋转
            else
                T=DoubleRightLeftRotation(T);	//RL旋转
    }
    
    T->Height=Max(GetHeight(T->Left),GetHeight(T->Right))+1;	//height为此子树的高度
    return T;
}
int main()
{
    int i,NodeNum,tmpkey;
    AVLTree tree=NULL;
    scanf("%d",&NodeNum);
    for(i=0;i<NodeNum;i++){
        scanf("%d",&tmpkey);
        tree=AVL_Insertion(tmpkey,tree);
        
    }
    
    printf("%d",tree->Data);
    
    return 0;      
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值