1007. Maximum Subsequence Sum (25)

1007. Maximum Subsequence Sum (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4
    在说这道题之前,容我小小地骄傲一些,在这道题目里我发现了一个测试数据小小的不足,亲民的姥姥还夸了一下我
 
     当我跟第二遍姥姥的数据结构课的时候,发现之前提交的代码有两个例子错了,那时真是激动万分,能得到姥姥的夸奖可谓三生有幸
     好吧,本人的自恋到此为止,下面讲正经的,这道题呢,你只要选过姥姥和何老师在MOOC上的数据结构,你是肯定会做的,如果你已经回了呢?我觉得你也不会在看这篇博文,如果你没选过姥姥和何老师的数据结构,那你最好去看《编程之美》这本书,然后编程之美这本书上讲的方法根本不如姥姥在课上讲的方法好,所以呢,最好还是去选一下姥姥的MOOC,姥姥为人和蔼又亲民,不去听一下枉为程序员。
     然后,直接上代码
# include <cstdio>
# include <iostream>

int main()
{
    int n;
    scanf("%d",&n);
    int cursum=0,curfirst,curlast,sum=0,first=0,last,temp,firstnum,lastnum,flag = 0,k=0;
    for (int i=0;i<n;i++)
    {
	    scanf("%d",&temp);
	    if (i==0)  firstnum = temp;
		if (i==n-1) lastnum = temp; 
		if (temp<0)
		    flag++;
	    cursum += temp;
	    curlast = temp;
	    if (k==0)
	        {
			curfirst = temp;
            k = 1;
			}
	    if (cursum<0)
	        {
			cursum = 0;
            k = 0;
		    }
	    if (cursum>sum)
	    {
		   first = curfirst;
		   last = curlast;
		   sum = cursum;
		}
	}
	if (flag==n)
	      printf("0 %d %d\n",firstnum,lastnum);
    else
          printf("%d %d %d\n",sum,first,last);
    return 0;
}


    
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值