1068. Find More Coins (30)搜索题

1068. Find More Coins (30)

时间限制
150 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 104 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=104, the total number of coins) and M(<=102, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the face values V1 <= V2 <= ... <= Vk such that V1 + V2 + ... + Vk = M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output "No Solution" instead.

Note: sequence {A[1], A[2], ...} is said to be "smaller" than sequence {B[1], B[2], ...} if there exists k >= 1 such that A[i]=B[i] for all i < k, and A[k] < B[k].

Sample Input 1:
8 9
5 9 8 7 2 3 4 1
Sample Output 1:
1 3 5
Sample Input 2:
4 8
7 2 4 3
Sample Output 2:
No Solution
    这道题目算是上面那道 1048. Find Coins (25)的进化版吧,PAT就是这样,历次考试的题目似乎会有一点承接关系。给你一组数a[n]、,和一个数m希望你找出字典序最少的一组数,使得该组数的和为m,其实就是深搜吧,本来如果数据量n小于63的话,是可以用位运算枚举,加上lowbit这样的小技巧,我估计会快的飞起来,然后数据量是10^4,那就只好老老实实深搜了。
# include <cstdio>
# include <algorithm>
using namespace std;


int n,m;
int Num[10005];
int ans[10005],E=0;

void dfs(int i,int sum,int End)
{//printf("i = %d sum = %d End = %d ",i,sum,End);
    static int flag = 1;
	if (flag==0)  return;
	if (sum==m)   flag = 0,E = End;/*This line of code should before line 16*/
    if (sum>=m)   return;
    if (i>=n)    return;
    
	ans[End++] = Num[i];
	dfs(i+1,sum+Num[i],End);
    
	End--;
	dfs(i+1,sum,End);
}
int main()
{
  int i,sum = 0;
  scanf("%d%d",&n,&m);  
  for (i=0;i<n;i++)
      {
	  scanf("%d",Num+i);
	  if (Num[i]>m)
          i--,n--;
	  else 
	      sum += Num[i];
	  }
  sort(Num,Num+n);
  //if (sum>=m)
       dfs(0,0,0);
  if (E==0)
    printf("No Solution\n");
  else
    for (i=0;i<E;i++)
        printf("%d%c",ans[i],i==E-1?'\n':' ');
  return 0    ;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值