1009. Product of Polynomials (25)

1009. Product of Polynomials (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6
     一道简单题,只要注意范围还有当系数为0的时候不输出就好了,数据范围2000,时间限制400ms,然后我就决定使用最蠢的方法。用一个double数组表示多项式,下标为幂指数,内容为系数。相乘的时候逐项相乘,比如第i项与第j项相乘,ans[i+j] += a[i]*b[j];简单愉快。最后扫一遍输出就好了。
# include <cstdio>
# include <cmath>

const int size = 2005;
const double eps = 1e-5; 

double ans[size];
double elem[2][size];

int main()
{
    int i,j,k,n;
    double an;
    for (i=0;i<size;i++)
        ans[i] = elem[0][i] = elem[1][i] = 0;
    for (i=0;i<2;i++)
      {
      	scanf("%d",&k);
      	while (k--)
          {
		    scanf("%d%lf",&n,&an);
		    elem[i][n] = an;
          }
	  }
	for (i=0;i<=1000;i++)
      for (j=0;j<=1000;j++)
	      ans[i+j] += elem[0][i]*elem[1][j];
    for (k=i=0;i<size;i++)
	      if (fabs(ans[i])>eps)
		      k++;
	printf("%d",k);
	for (i=size-1;i>-1;i--)
	    if (fabs(ans[i])>eps)
		    printf(" %d %.1lf",i,ans[i]);
	printf("\n");        
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值