hdu5880Family View(AC自动机)

Family View

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 707    Accepted Submission(s): 128


Problem Description
Steam is a digital distribution platform developed by Valve Corporation offering digital rights management (DRM), multiplayer gaming and social networking services. A family view can help you to prevent your children access to some content which are not suitable for them. 

Take an MMORPG game as an example, given a sentence T, and a list of forbidden words {P}, your job is to use '*' to subsititute all the characters, which is a part of the substring matched with at least one forbidden word in the list (case-insensitive).

For example, T is: "I love Beijing's Tiananmen, the sun rises over Tiananmen. Our great leader Chairman Mao, he leades us marching on."

And {P} is: {"tiananmen", "eat"}

The result should be: "I love Beijing's *********, the sun rises over *********. Our gr*** leader Chairman Mao, he leades us marching on."
 

Input
The first line contains the number of test cases. For each test case:
The first line contains an integer  n , represneting the size of the forbidden words list  P . Each line of the next  n  lines contains a forbidden words  Pi (1|Pi|1000000,|Pi|1000000)  where  Pi  only contains lowercase letters.

The last line contains a string  T (|T|1000000) .
 

Output
For each case output the sentence in a line.
 

Sample Input
  
  
1 3 trump ri o Donald John Trump (born June 14, 1946) is an American businessman, television personality, author, politician, and the Republican Party nominee for President of the United States in the 2016 election. He is chairman of The Trump Organization, which is the principal holding company for his real estate ventures and other business interests.
 

Sample Output
  
  
D*nald J*hn ***** (b*rn June 14, 1946) is an Ame**can businessman, televisi*n pers*nality, auth*r, p*litician, and the Republican Party n*minee f*r President *f the United States in the 2016 electi*n. He is chairman *f The ***** *rganizati*n, which is the p**ncipal h*lding c*mpany f*r his real estate ventures and *ther business interests.

 

题意:敏感词屏蔽,给一堆敏感词,给一段文本,要求把文本中所有的敏感词用*代替。

题解:对敏感词建出AC自动机,在AC自动机上跑文本,就可以得到文本的每个前缀的最长匹配后缀,扫一遍即可得到结果。

AC代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
const int maxn=1100000;
int d[maxn],ans[maxn];
struct Trie{
	int next[maxn][26],fail[maxn],end[maxn];
	int root,L;
	int newnode(){
		for(int i=0;i<26;i++)
			next[L][i]=-1;
		end[L++]=0;
		return L-1;
	}
	void init(){
		L=0;
		root=newnode();
	}
	void insert(char buf[]){
		int len=strlen(buf);
		int now=root;
		for(int i=0;i<len;i++){
			if(next[now][buf[i]-'a']==-1)
				next[now][buf[i]-'a']=newnode();
			now=next[now][buf[i]-'a'];
		}
		end[now]=1;
		d[now]=len;
	}
	void build(){
		queue<int> 	q;
		fail[root]=root;
		for(int i=0;i<26;i++)
			if(next[root][i]==-1)
				next[root][i]=root;
			else{
				fail[next[root][i]]=root;
				q.push(next[root][i]);
			}
		while(!q.empty()){
			int now=q.front();
			q.pop();
			for(int i=0;i<26;i++)
				if(next[now][i]==-1)
					next[now][i]=next[fail[now]][i];
				else{
					fail[next[now][i]]=next[fail[now]][i];
					q.push(next[now][i]);
				}
		}
	}
	void slove(char buf[]){
		int len=strlen(buf);
		int now=root;
		int index;
		for(int i=0;i<len;i++){
			if(buf[i]>='a'&&buf[i]<='z')
				index=buf[i]-'a';
			else if(buf[i]>='A' && buf[i]<='Z')
				index=buf[i]-'A';
			else continue;
			now=next[now][index];
			int temp=now;
			while(temp!=root){
				if(end[temp]){
					ans[i+1]-=1;
					ans[i-d[temp]+1]+=1;
					break;	
				}
				temp=fail[temp];
			}
		}
	}
};
char buf[maxn];
Trie ac;
int main(){
	int T,i,n,len;
	scanf("%d",&T);
	while(T--){
		scanf("%d",&n);
		ac.init();
		for(int i=0;i<n;i++){
			scanf("%s",buf);
			ac.insert(buf);
		}
		getchar();
		ac.build();
		gets(buf);
		memset(ans,0,sizeof(ans));
		ac.slove(buf);
		long long res=0;
		len=strlen(buf);
		for(int i=0;i<len;i++){
			res+=ans[i];
			if(res<=0)
				printf("%c",buf[i]);
			else printf("*");
		}
		puts("");
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值