hdu5900QSC and Master(区间dp)

QSC and Master

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 745    Accepted Submission(s): 275


Problem Description
Every school has some legends, Northeastern University is the same.

Enter from the north gate of Northeastern University,You are facing the main building of Northeastern University.Ninety-nine percent of the students have not been there,It is said that there is a monster in it.

QSCI am a curious NEU_ACMer,This is the story he told us.

It’s a certain period,QSCI am in a dark night, secretly sneaked into the East Building,hope to see the master.After a serious search,He finally saw the little master in a dark corner. The master said:

“You and I, we're interfacing.please solve my little puzzle!

There are N pairs of numbers,Each pair consists of a key and a value,Now you need to move out some of the pairs to get the score.You can move out two continuous pairs,if and only if their keys are non coprime(their gcd is not one).The final score you get is the sum of all pair’s value which be moved out. May I ask how many points you can get the most?

The answer you give is directly related to your final exam results~The young man~”

QSC is very sad when he told the story,He failed his linear algebra that year because he didn't work out the puzzle.

Could you solve this puzzle?

(Data range:1<=N<=300
1<=Ai.key<=1,000,000,000
0<Ai.value<=1,000,000,000)
 

Input
First line contains a integer T,means there are T(1≤T≤10) test case。

  Each test case start with one integer N . Next line contains N integers,means Ai.key.Next line contains N integers,means Ai.value.
 

Output
For each test case,output the max score you could get in a line.
 

Sample Input
  
  
3 3 1 2 3 1 1 1 3 1 2 4 1 1 1 4 1 3 4 3 1 1 1 1
 

Sample Output
  
  
0 2 0
 

题意:

给出n对数keyi,vali表示当前这对数的键值和权值,可以操作将连续的两个数合并,如果满足gcd(a[i],a[i+1])>1,得到

的价值是两个数的权值和,每次合并两个数之后,这两个数就会消失,然后旁边的数会接上

比如1 2 3 4 合并了 2 3 则 剩下1 4也可以合并

思路:

求出区间l,r能否全部消除,区间dp一下就好

dp[l][r]=max(dp[l][r],dp[l][k]+dp[k+1][r]);
AC代码:
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
const int maxn=1100000;
int d[maxn],ans[maxn];
struct Trie{
	int next[maxn][26],fail[maxn],end[maxn];
	int root,L;
	int newnode(){
		for(int i=0;i<26;i++)
			next[L][i]=-1;
		end[L++]=0;
		return L-1;
	}
	void init(){
		L=0;
		root=newnode();
	}
	void insert(char buf[]){
		int len=strlen(buf);
		int now=root;
		for(int i=0;i<len;i++){
			if(next[now][buf[i]-'a']==-1)
				next[now][buf[i]-'a']=newnode();
			now=next[now][buf[i]-'a'];
		}
		end[now]=1;
		d[now]=len;
	}
	void build(){
		queue<int> 	q;
		fail[root]=root;
		for(int i=0;i<26;i++)
			if(next[root][i]==-1)
				next[root][i]=root;
			else{
				fail[next[root][i]]=root;
				q.push(next[root][i]);
			}
		while(!q.empty()){
			int now=q.front();
			q.pop();
			for(int i=0;i<26;i++)
				if(next[now][i]==-1)
					next[now][i]=next[fail[now]][i];
				else{
					fail[next[now][i]]=next[fail[now]][i];
					q.push(next[now][i]);
				}
		}
	}
	void slove(char buf[]){
		int len=strlen(buf);
		int now=root;
		int index;
		for(int i=0;i<len;i++){
			if(buf[i]>='a'&&buf[i]<='z')
				index=buf[i]-'a';
			else if(buf[i]>='A' && buf[i]<='Z')
				index=buf[i]-'A';
			else continue;
			now=next[now][index];
			int temp=now;
			while(temp!=root){
				if(end[temp]){
					ans[i+1]-=1;
					ans[i-d[temp]+1]+=1;
					break;	
				}
				temp=fail[temp];
			}
		}
	}
};
char buf[maxn];
Trie ac;
int main(){
	int T,i,n,len;
	scanf("%d",&T);
	while(T--){
		scanf("%d",&n);
		ac.init();
		for(int i=0;i<n;i++){
			scanf("%s",buf);
			ac.insert(buf);
		}
		getchar();
		ac.build();
		gets(buf);
		memset(ans,0,sizeof(ans));
		ac.slove(buf);
		long long res=0;
		len=strlen(buf);
		for(int i=0;i<len;i++){
			res+=ans[i];
			if(res<=0)
				printf("%c",buf[i]);
			else printf("*");
		}
		puts("");
	}
	return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值