PAT 1143.Lowest Common Ancestor(30 分)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

 二叉树的中序一定是递增序列 先序递增排序得到中序 先序+中序得到唯一一棵树,二叉树的两个结点u,v的共同祖先root一定是一个>=root,一个<=root;都大于当前结点 必在结点右子树,都小于 必在结点左子树。

#include <stdio.h>
#include <algorithm>
#include <stdlib.h>
#include <stack>
#define null 0;
using namespace std;
bool cmp(int x,int y)
{
    return x<y;
}
typedef struct BitNode{
    int data;
    struct BitNode *rchild,*lchild;
}BitNode,*BitTree;
int n,m;
stack<BitTree> s;
BitTree buildTree(int pre[],int in[],int l1,int h1,int l2,int h2)
{
    BitNode *root=(BitNode *)malloc(sizeof(BitNode));
    root->data=pre[l1];
    int i=0;
    while(in[i]!=root->data)
        i++;
    //printf("%d  ",i);
    int llen=i-l2;
    int rlen=h2-i;
    if(llen)
        root->lchild=buildTree(pre, in, l1+1, l1+llen, l2, l2+llen-1);
    else
        root->lchild=null;
    if(rlen)
        root->rchild=buildTree(pre,in,h1-rlen+1,h1,h2-rlen+1,h2);
    else
        root->rchild=null;
    return root;
}
//结点是否在树中
int isExist(BitTree root,int a)
{
    if(!root)
    {
        return 0;
    }
    int temp=root->data;
    if(a==temp)
    {
        return 1;
    }else if(a<temp){
        return isExist(root->lchild,a);
    }else if(a>temp){
        return isExist(root->rchild,a);
    }
    return 0;
}
//排除无公共结点的情况
int  found(BitTree root,int a,int b)
{
    if(!isExist(root,a)&&!isExist(root,b))
    {
        printf("ERROR: %d and %d are not found.\n",a,b);
        return 0;
    }else if(!isExist(root,a)){
        printf("ERROR: %d is not found.\n",a);
        return 0;
    }else if(!isExist(root,b)){
        printf("ERROR: %d is not found.\n",b);
        return 0;
    }
    return 1;
}
//从根开始寻找两结点的公共结点
//a<root<b root必是公共结点
//root<a <b 公共结点在其右子树
//root>a >b 在左子树
void search(BitTree root,int a,int b)
{
        int temp=root->data;
    
        if(temp==a)
            printf("%d is an ancestor of %d.\n",a,b);
        else if(temp==b)
            printf("%d is an ancestor of %d.\n",b,a);
        if((temp>a&&temp<b)|| (temp>b&&temp<a))
            printf("LCA of %d and %d is %d.\n",a,b,temp);
        else if(temp>a&&temp>b)
            search(root->lchild,a,b);
        else if(temp<a&&temp<b)
            search(root->rchild,a,b);
    
}
int main()
{
    scanf("%d %d",&m,&n);
    int preOrder[n];
    int inOrder[n];
    for(int i=0;i<n;i++)
    {
        scanf("%d",&preOrder[i]);
        inOrder[i]=preOrder[i];
    }
    sort(inOrder,inOrder+n,cmp);

    //preorder+inorder=build tree
    BitTree p=buildTree(preOrder,inOrder,0,n-1,0,n-1);
    
    while(m--)
    {
        int a,b;
        scanf("%d %d",&a,&b);
        if(found(p,a,b))
            search(p,a,b);
    }
    return 0;
}

 


另一种思路,先序遍历过程即寻值过程,先得到>=u <=v||<=u >=v的pre[i]=a,a就是u,v的祖先。from 柳婼 の blog

#include <iostream>
#include <vector>
#include <map>
using namespace std;
map<int, bool> mp;
int main() {
    int m, n, u, v, a;
    scanf("%d %d", &m, &n);
    vector<int> pre(n);
    for (int i = 0; i < n; i++) {
        scanf("%d", &pre[i]);
        mp[pre[i]] = true;
    }
    for (int i = 0; i < m; i++) {
        scanf("%d %d", &u, &v);
        for(int j = 0; j < n; j++) {
            a = pre[j];
            if ((a >= u && a <= v) || (a >= v && a <= u)) break;
        } 
        if (mp[u] == false && mp[v] == false)
            printf("ERROR: %d and %d are not found.\n", u, v);
        else if (mp[u] == false || mp[v] == false)
            printf("ERROR: %d is not found.\n", mp[u] == false ? u : v);
        else if (a == u || a == v)
            printf("%d is an ancestor of %d.\n", a, a == u ? v : u);
        else
            printf("LCA of %d and %d is %d.\n", u, v, a);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是C#中二叉树lowest common ancestor的源代码: ```csharp using System; public class Node { public int value; public Node left; public Node right; public Node(int value) { this.value = value; this.left = null; this.right = null; } } public class BinaryTree { public Node root; public BinaryTree() { this.root = null; } public Node LowestCommonAncestor(Node node, int value1, int value2) { if (node == null) { return null; } if (node.value == value1 || node.value == value2) { return node; } Node left = LowestCommonAncestor(node.left, value1, value2); Node right = LowestCommonAncestor(node.right, value1, value2); if (left != null && right != null) { return node; } return (left != null) ? left : right; } } public class Program { public static void Main() { BinaryTree tree = new BinaryTree(); tree.root = new Node(1); tree.root.left = new Node(2); tree.root.right = new Node(3); tree.root.left.left = new Node(4); tree.root.left.right = new Node(5); tree.root.right.left = new Node(6); tree.root.right.right = new Node(7); Node lca = tree.LowestCommonAncestor(tree.root, 4, 5); Console.WriteLine("Lowest Common Ancestor of 4 and 5: " + lca.value); lca = tree.LowestCommonAncestor(tree.root, 4, 6); Console.WriteLine("Lowest Common Ancestor of 4 and 6: " + lca.value); lca = tree.LowestCommonAncestor(tree.root, 3, 4); Console.WriteLine("Lowest Common Ancestor of 3 and 4: " + lca.value); lca = tree.LowestCommonAncestor(tree.root, 2, 4); Console.WriteLine("Lowest Common Ancestor of 2 and 4: " + lca.value); } } ``` 在上面的代码中,我们定义了一个Node类和一个BinaryTree类。我们使用BinaryTree类来创建二叉树,并实现了一个LowestCommonAncestor方法来计算二叉树中给定两个节点的最近公共祖先。 在LowestCommonAncestor方法中,我们首先检查给定节点是否为null或与给定值之一匹配。如果是,则返回该节点。否则,我们递归地在左子树和右子树上调用LowestCommonAncestor方法,并检查它们的返回值。如果左子树和右子树的返回值都不为null,则当前节点是它们的最近公共祖先。否则,我们返回非null的那个子树的返回值。 在Main方法中,我们创建了一个二叉树,并测试了LowestCommonAncestor方法的几个不同输入。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值