PAT 1020. Tree Traversals

1020. Tree Traversals (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2
 
 
思路就是递归,后续遍历根节点总是最后一个,然后在中序遍历中找到该值就可以判断左右数各有多少个,然后在递归,可以参考剑指Offer面试题:5.重建二叉树
import java.util.LinkedList;
import java.util.Queue;
import java.util.Scanner;

public class Main {
	
	static class Node {
		Node left, right;
		int val;
		public Node(int val) {
			this.val = val;
		}
	}
	
	static int[] postOrder, inOrder;
	
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		
		int N = sc.nextInt();
		postOrder = new int[N];
		inOrder   = new int[N];
		
		for(int i=0; i<N; i++)
			postOrder[i] = sc.nextInt();
		
		for(int i=0; i<N; i++)
			inOrder[i] = sc.nextInt();
		
		Node root = reconstruct(0, N-1, 0, N-1);
		levelOrder(root);
	}

	private static void levelOrder(Node root) {
		StringBuilder sb = new StringBuilder();
		Queue<Node> q = new LinkedList<Node>();
		q.add(root);
		while(!q.isEmpty()) {
			Node p = q.remove();
			sb.append(p.val + " ");
			if(p.left != null)
				q.add(p.left);
			if(p.right != null)
				q.add(p.right);
		}
		System.out.println(sb.toString().trim());
	}

	private static Node reconstruct(int ps, int pt, int is, int it) {
		
		if(ps == pt)	return new Node(postOrder[ps]);
		
		int root_val = postOrder[pt];
		int root_position = 0;
		for(int i=is; i<=it; i++)
			if(inOrder[i] == root_val) {
				root_position = i;
				break;
			}
		Node root = new Node(root_val);
//		System.out.printf("%d %d %d %d\n", ps, ps+root_position-1-is, is, root_position-1);
//		System.out.printf("%d %d %d %d\n", ps+root_position-is, pt-1, root_position+1, it);
		if(ps+root_position-is-1 >= ps)
			root.left  = reconstruct(ps, ps+root_position-is-1, is, root_position-1);
		if(pt-1 >= ps+root_position-is)
			root.right = reconstruct(ps+root_position-is, pt-1, root_position+1, it);
		return root;
	}


}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值