1:问题描述
Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
’.’ - a black tile
’#’ - a red tile
’@’ - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
….#.
…..#
……
……
……
……
……
#@…#
.#..#.
11 9
.#………
.#.#######.
.#.#…..#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#…….#.
.#########.
………..
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
…@…
###.###
..#.#..
..#.#..
0 0
Sample Output
45
59
6
13
2:大致题意
“#”是栏杆,点点是路。要求@可以走多少个点点。
3:思路
也是BFS,方向数组遍历4个方向,每个方向走一遍,是点点就标记并总和加一。
4:感想
这会一点都不困了。。
好晚了呀。
5:ac代码
#include<iostream>
#include<string.h>
#include<set>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<queue>
#include<iomanip>
#include<cstdio>
using namespace std;
int n,m;
char map[30][30];
struct ans
{
int x;
int y;
}n1,n2;
int ww(int a,int b)
{
if(a>0&&a<=m&&b>0&&b<=n)
return 1;
return 0;
}
int BFS(int k,int z)
{
int num=0,i;
n1.x=k;
n1.y=z;
int disx[6]={-1,1,0,0};
int disy[6]={0,0,-1,1};
queue<ans> Q;
Q.push(n1);
while(!Q.empty())
{
n1=Q.front();
Q.pop();
for(i=0;i<4;i++)
{
n2.x=n1.x+disx[i];
n2.y=n1.y+disy[i];
if(ww(n2.x,n2.y)&&map[n2.x][n2.y]=='.')
{
num++;
Q.push(n2);
map[n2.x][n2.y]='#';
}
}
}
return num+1;
}
int main()
{
//freopen("r.txt","r",stdin);
int j,i,t,k,z;
char x;
while(cin>>n>>m&&n!=0||m!=0)
{
for(i=1;i<=m;i++)
{
for(j=1;j<=n;j++)
{
cin>>map[i][j];
if(map[i][j]=='@') {k=i;z=j;}
}
}
t=BFS(k,z);
cout<<t<<endl;
}
return 0;
}