SDAU dp专题 1005

1:问题描述
Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn’t be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format “Case case: maximum height = height”.

Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

2:大致题意

已知箱子的长宽高,并且每个箱子有无数个。
如果一个箱子的长和宽严格大于另一个箱子的长和宽。那么就可以放在这个箱子上面。
求出箱子可以摞的最大高度。

3:思路

这个题和第3题的思路一样。只需要转化一下。
因为箱子有无限个。所以输入一组数据,就向数组里放3个元素~
这时候要注意,箱子的长要大于等于宽!
然后对结构体进行排序,先按长排,如果长相等的话就按宽排。
再从头遍历就行了~和第3题步骤一样。下面贴代码。

4:感想

转化的时候挺麻烦的,一开始没有规定箱子的长大于宽,wa了几次,后来找到了一组样例通不过。。改了一下就过了。

5:ac代码

#include<iostream>
#include<string.h>
#include<set>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<map>
#include<queue>
#include<iomanip>
#include<cstdio>
using namespace std;
struct ans
{
    int x,y,z;
}ww[500];
int dp[1005];
bool comp(ans a,ans b)
{
    if(a.x<b.x) return true;
    if(a.x==b.x && a.y<b.y) return true;
    return false;
}
int main()
{
    //freopen("r.txt","r",stdin);
    int n,m,t,a,b,c,i,j,k;
    t=0;
    k=1;
    while(cin>>n && n!=0)
    {
        int maxx;
        int pp=0;
        memset(dp,0,sizeof(dp));
        for(i=0;i<n;i++)
        {
            cin>>a>>b>>c;
            ww[pp].z=c;
            ww[pp].x=max(a,b);
            ww[pp].y=min(a,b);
            ww[++pp].z=a;
            ww[pp].x=max(c,b);
            ww[pp].y=min(c,b);
            ww[++pp].z=b;
            ww[pp].x=max(a,c);
            ww[pp++].y=min(a,c);
        }
        sort(ww,ww+pp,comp);
        for(i=0;i<pp;i++)
            dp[i]=ww[i].z;
        for(i=1;i<pp;i++)
        {
            //cout<<ww[i].x<<" "<<ww[i].y<<" "<<ww[i].z<<endl;
            maxx=0;
            for(j=0;j<i;j++)
            {
                if(ww[i].x>ww[j].x && ww[i].y>ww[j].y && dp[j]>maxx)
                    maxx=dp[j];
            }
            dp[i]=maxx+ww[i].z;
            //cout<<dp[i]<<endl;
        }
        maxx=-1;
        for(i=1;i<=3*n;i++)
        {
            if(dp[i]>maxx) maxx=dp[i];
        }
        cout<<"Case "<<k++<<": maximum height = ";
        cout<<maxx<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值