poj 1564 Sum It Up DFS

题目描述:
Description

Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t = 4, n = 6, and the list is [4, 3, 2, 2, 1, 1], then there are four different sums that equal 4: 4, 3+1, 2+2, and 2+1+1. (A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.
Input

The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x 1 , … , x n . If n = 0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12 (inclusive), and x 1 , … , x n will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.
Output

For each test case, first output a line containing Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the lineNONE’. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distinct; the same sum cannot appear twice.
Sample Input

4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0
Sample Output

Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25

大致题意:

输入 t,n。
n个数中找出和为t的组合。

思路分析:

明显是DFS。
首先要找DFS的参数。
当前检索的数的下标。存在结果的数组里的下标。还要有和剩余多少。
其他的就是很基本的dfs套路了。
感觉dfs这掌握的不太好,数位,树形dp,经常用。所以最近又刷了几道题。

ac代码:

#include<iostream>
using namespace std;
int t,n,flag;
int a[1005];
int r[1005];
void dfs(int len,int bit,int next)
{
    if(next==0)
    {
        flag=1;
        for(int i=0;i<bit;i++)
        {
            if(i==0)
                cout<<r[i];
            else
                cout<<"+"<<r[i];
        }
        cout<<endl;
    }
    for(int i=len;i<n;i++)
    {
        if((i==len || a[i]!=a[i-1]) && next-a[i]>=0) //去重。
        {
            r[bit]=a[i];
            dfs(i+1,bit+1,next-a[i]);
        }
    }
}
int main()
{
    ios::sync_with_stdio(false);
    while(cin>>t>>n && t+n)
    {
        flag=0;
        for(int i=0;i<n;i++)
        {
            cin>>a[i];
        }
        cout<<"Sums of "<<t<<":"<<endl;
        dfs(0,0,t);
        if(!flag)
            cout<<"NONE"<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值