题目链接:点这里
Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is 4,3,2,2,1,14,3,2,2,1,1, then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.
Input
The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.
Output
For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.
Sample Input
4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0
Sample Output
Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25
题意:
给你一个数sum,然后给你n个数,求这个n个数的和能组成sum的有多少种情况,并且n的数的排列是非递增的.
思路:
从第一数开始暴力搜索,但是要注意一些特殊情况,否则会输出重复的解,特殊情况就是你需要判重,你这次已经使用了这个数,那么下一次枚举的数不能还是从与当前枚举的数相同的数开始
代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cmath>
using namespace std;
int a[20];
int n,sum;
int ans;
int b[20];
bool vis[20];
bool flag;
void dfs(int i,int k,int num)
{
if(num==sum){
for(int i=1;i<k-1;++i)
cout<<b[i]<<'+';
cout<<b[k-1]<<endl;
flag=false;
return ;
}
if(num>sum)
return ;
int x=sum+1;
for(int j=i;j<=n;++j)
if(x!=a[j]) {//判重,使每次的情况不一样
b[k]=a[j];
x=a[j];
dfs(j+1,k+1,num+a[j]);
}
}
int main()
{
while(scanf("%d %d",&sum,&n)!=EOF&&n){
for(int i=1;i<=n;++i)
scanf("%d",&a[i]);
flag=true;
memset(vis,false,sizeof(vis));
cout<<"Sums of "<<sum<<':'<<endl;
dfs(1,1,0);
if(flag)
cout<<"NONE"<<endl;
}
return 0;
}