Poj 2165 Milking Grid(kmp)

Milking Grid
Time Limit: 3000MS Memory Limit: 65536K
Description
Every morning when they are milked, the Farmer John’s cows form a rectangular grid that is R (1 <= R <= 10,000) rows by C (1 <= C <= 75) columns. As we all know, Farmer John is quite the expert on cow behavior, and is currently writing a book about feeding behavior in cows. He notices that if each cow is labeled with an uppercase letter indicating its breed, the two-dimensional pattern formed by his cows during milking sometimes seems to be made from smaller repeating rectangular patterns.
Help FJ find the rectangular unit of smallest area that can be repetitively tiled to make up the entire milking grid. Note that the dimensions of the small rectangular unit do not necessarily need to divide evenly the dimensions of the entire milking grid, as indicated in the sample input below.
Input
* Line 1: Two space-separated integers: R and C
* Lines 2..R+1: The grid that the cows form, with an uppercase letter denoting each cow’s breed. Each of the R input lines has C characters with no space or other intervening character.
Output
* Line 1: The area of the smallest unit from which the grid is formed
Sample Input
2 5
ABABA
ABABA
Sample Output
2
Hint
The entire milking grid can be constructed from repetitions of the pattern ‘AB’.
Source
USACO 2003 Fall

/*
kmp.
一开始传参数呵呵了.
忘了n和m相等的情况.
先把行看做一个整体做kmp.
然后把列看做一个整体做kmp.
*/
#include<iostream>
#include<cstdio>
#include<cstring>
#define MAXN 10001
#define MAXM 81
using namespace std;
int n,m,k,w,next[MAXN];
char g[MAXN][MAXM];
bool check(int x,int y,bool flag)
{
    if(flag)
    {
        for(int i=1;i<=m;i++) if(g[x][i]!=g[y][i]) return false;
        return true;
    }
    else
    {
        for(int i=1;i<=k;i++) if(g[i][x]!=g[i][y]) return false;
        return true;
    }
}
void kmp(int x,bool flag)
{
    int p=0;
    for(int i=2;i<=x;i++)
    {
        p=next[i-1];
        while(p&&!check(i,p+1,flag)) p=next[p];
        if(check(i,p+1,flag)) p++;
        next[i]=p;
    }
}
void slove()
{
    kmp(n,1);k=n-next[n];
    memset(next,0,sizeof next);
    kmp(m,0);w=m-next[m];
    return ;
}
int main()       
{
    scanf("%d %d",&n,&m);
    for(int i=1;i<=n;i++)
      for(int j=1;j<=m;j++)
        cin>>g[i][j];       
    slove();
    printf("%d\n",k*w);
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值