【poj 2185 Milking Grid】 KMP*2

Milking Grid
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 7365 Accepted: 3153
Description

Every morning when they are milked, the Farmer John’s cows form a rectangular grid that is R (1 <= R <= 10,000) rows by C (1 <= C <= 75) columns. As we all know, Farmer John is quite the expert on cow behavior, and is currently writing a book about feeding behavior in cows. He notices that if each cow is labeled with an uppercase letter indicating its breed, the two-dimensional pattern formed by his cows during milking sometimes seems to be made from smaller repeating rectangular patterns.

Help FJ find the rectangular unit of smallest area that can be repetitively tiled to make up the entire milking grid. Note that the dimensions of the small rectangular unit do not necessarily need to divide evenly the dimensions of the entire milking grid, as indicated in the sample input below.

Input

  • Line 1: Two space-separated integers: R and C

  • Lines 2..R+1: The grid that the cows form, with an uppercase letter denoting each cow’s breed. Each of the R input lines has C characters with no space or other intervening character.
    Output

  • Line 1: The area of the smallest unit from which the grid is formed
    Sample Input

2 5
ABABA
ABABA
Sample Output

2
Hint

The entire milking grid can be constructed from repetitions of the pattern ‘AB’.
Source

题意:N*M 的矩阵,问上左严格重叠的情况下最小能覆盖矩阵。
思路:ansn ,ansm互不干扰,分别求出lcm;printf ansn*ansm

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int N,M;
char s[10005][75];
int nex[10005];
int ann,anm;
int gcd(int a,int b)
{
    if(b==0) return a;
    return gcd(b,a%b);
}
int lcm(int x,int y)
{
    return x/gcd(x,y)*y;
}
inline int get_nex(int x,int id)
{
    if(id==0)
    {
        int len=M;  
        nex[0]=-1;
        int j=-1;
        for(int i=0;i<len;i++)
        {
            while(j!=-1&&s[x][i]!=s[x][j+1]) j=nex[j];
            if(s[x][i]==s[x][j+1]&&i!=0) j++;
            nex[i]=j;
        }
        return len-nex[len-1]-1;
    }
    else
    {
        int len=N;
        nex[0]=-1;
        int j=-1;
        for(int i=0;i<len;i++)
        {
            while(j!=-1&&s[i][x]!=s[j+1][x]) j=nex[j];
            if(s[i][x]==s[j+1][x]&&i!=0) j++;
            nex[i]=j;
        }
        return len-nex[len-1]-1;
    }
}
int main()
{
    scanf("%d%d",&N,&M);
    for(int i=0;i<N;i++)
    for(int j=0;j<M;j++)
    {
        scanf(" %c",&s[i][j]);      
    }
    ann=1; anm=1;
    for(int i=0;i<N;i++) ann=lcm(get_nex(i,0),ann);
    ann=min(ann,M);
    for(int j=0;j<M;j++) anm=lcm(get_nex(j,1),anm);
    anm=min(anm,N);
    cout<<ann*anm;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值