Calculate a + b and output the sum in standard format – that is, the
digits must be separated into groups of three by commas (unless there
are less than four digits).Input
Each input file contains one test case. Each case contains a pair of
integers a and b where -1000000 <= a, b <= 1000000. The numbers are
separated by a space.Output
For each test case, you should output the sum of a and b in one line.
The sum must be written in the standard format.Sample Input
-1000000 9 Sample Output
-999,991
链接
#define _CRT_SECURE_NO_WARNINGS
#include<iostream>
#include<stdio.h>
#include<string>
using namespace std;
int main()
{
int a, b;
while (scanf("%d%d",&a,&b)!=EOF)
{
int sum = a + b;
string s;
//如果是负数
if (sum < 0)
{
printf("-");
sum *= -1;
}
int cur = 0;
do
{
int r = sum % 10;
sum /= 10;
if (cur < 3)
{
s.insert(s.begin(), r + '0');
cur++;
}
else
{
s.insert(s.begin(), ',');
s.insert(s.begin(), r + '0');
cur = 1;
}
} while (sum > 0);
cout << s << endl;
}
}