POJ-3176 Cow Bowling

1 篇文章 0 订阅

The cows don’t use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this:

       7



     3   8



   8   1   0



 2   7   4   4



4   5   2   6   5

Then the other cows traverse the triangle starting from its tip and moving “down” to one of the two diagonally adjacent cows until the “bottom” row is reached. The cow’s score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame.

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input
Line 1: A single integer, N
Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.
Output
Line 1: The largest sum achievable using the traversal rules

Sample Input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output
30

Hint
Explanation of the sample:

        7

       *

      3   8

     *

    8   1   0

     *

  2   7   4   4

     *

4   5   2   6   5

The highest score is achievable by traversing the cows as shown above.

大概意思就是说,像金字塔一样输入一组数字,每一排取一个数字求和。但是取出的数字必须和上面的数字直接相邻。问每一组数据能取出的最大和是多少。

其实是个DP的最简单的水题。。。
但是我最开始,是用函数递归做的,超时了。。。
后来,才想起来用数组可以直接做,,,
还是做题做的太少了。。。

#include<iostream>
#include<stdio.h>
using namespace std;

int i, j, k, t;
int s, N, m;
int a[355][355];

/*void f2(int i, int j,int sum)
{
    if (i == N - 1)
    {
        if (a[i][j] + sum >= m)
            m = sum + a[i][j];
        if (a[i][j] + sum >= m)
            m = sum + a[i][j];
    }
    if ((i < (N - 1)) && i>0)//一直到这一行的和
    {
        dfs(i + 1,j, sum + a[i][j]);
        dfs(i + 1, j+1,sum + a[i][j+1]);
    }
    if (i == 0)
    {
        dfs(i+1, j,sum + a[i][j]);
    }
}这一部分是递归的时候写的函数。。。超时。。。*/

int f(int i, int j)
{
    if (i >= j)
        return i;
    else return j;
}
int main()
{
    while (cin >> N)
    {
        for (i = 0; i < N; i++)
            for (j = 0; j <= i; j++)
            {
                scanf("%d", &a[i][j]);
            }
        for (i = N - 1; i >= 0; i--)
            for (j = 0; j <= i; j++)
                a[i][j] = a[i][j] + f(a[i + 1][j], a[i + 1][j + 1]);
        cout << a[0][0];
    }
    return 0;
}
04-27 2008
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值