VUA-10375 Choose and divide

The binomial coefficient C(m, n) is defined as
C(m, n) = m!/[(m − n)! n!]
Given four natural numbers p, q, r, and s, compute the the result of dividing C(p, q) by C(r, s).

Input

Input consists of a sequence of lines. Each line contains four non-negative integer numbers giving values
for p, q, r, and s, respectively, separated by a single space. All the numbers will be smaller than 10,000
with p ≥ q and r ≥ s.

Output

For each line of input, print a single line containing a real number with 5 digits of precision in the fraction,
giving the number as described above. You may assume the result is not greater than 100,000,000.

Sample Input

10 5 14 9
93 45 84 59
145 95 143 92
995 487 996 488
2000 1000 1999 999
9998 4999 9996 4998

Sample Output

0.12587
505606.46055
1.28223
0.48996
2.00000
3.99960

题意:
计算组合数公式。
数据会很大,直接算会超范围。
观察一下,这个公式中分子和分母中相乘的数字个数是一样的。
所以可以乘一个数字的同时除一个数字,正好计算完毕,不会超范围
对于这个公式,进行化简,可以化简称两种情况,对应两种情况。
对r、s和p、q但读进行约分化简
p!/[q!(p-q)!] = p*(p-1)(q+1)/(p-q)!
p!/[q!(p-q)!] =p*(p-1)(p-q+1))/q!

s!(r-s)!/r! =(r-s)!/[r(r-1)(s+1)]
s!(r-s)!/r! =s!/[r(r-1)(r-s+1)]

这两种情况,根据p-q和q的大小(r-s和s的大小)来取舍,
显然选择计算量较小的。

#include <stdio.h>  

int p, q, r, s, i;  
double ans;  
int main () {  
    while (~scanf("%d%d%d%d", &p, &q, &r, &s)) {  
        ans = 1.0;  
        if (p - q < q)  
            q = p - q;  
        if (r - s < s)  
            s = r - s;  
        for (i = 1; i <= q || i <= s; i ++) {  
            if (i <= q) {  
                ans = ans * (p - q + i) / i;  
            }  
            if (i <= s) {  
                ans = ans / (r - s + i) * i;  
            }  
        }  
        printf("%.5lf\n", ans);  
    }  
    return 0;  
}  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
04-27 1999

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值