Hdu 5875 Function 线段树

Function

Time Limit: 7000/3500 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 3113    Accepted Submission(s): 1035


Problem Description
The shorter, the simpler. With this problem, you should be convinced of this truth.
  
  You are given an array  A  of  N  postive integers, and  M  queries in the form  (l,r) . A function  F(l,r) (1lrN)  is defined as:
F(l,r)={AlF(l,r1) modArl=r;l<r.
You job is to calculate  F(l,r) , for each query  (l,r) .
 

Input
There are multiple test cases.
  
  The first line of input contains a integer  T , indicating number of test cases, and  T  test cases follow. 
  
  For each test case, the first line contains an integer  N(1N100000) .
  The second line contains  N  space-separated positive integers:  A1,,AN (0Ai109) .
  The third line contains an integer  M  denoting the number of queries. 
  The following  M  lines each contain two integers  l,r (1lrN) , representing a query.
 

Output
For each query (l,r) , output  F(l,r)  on one line.
 

Sample Input
  
  
1 3 2 3 3 1 1 3
 

Sample Output
  
  
2
 

Source


多次查询,求a[l]%a[l+1]%...%a[r].


每次求余,若当前数比被除数大,则最多为原数一半,所以每次查询,有效的运算最多log(a[l])次。

如此,只要用线段树求区间内第一个不大于当前数的数的位置。

不断暴力查询,更新答案即可。


#include <cstdio>
#include <iostream>
#include <string.h>
#include <string> 
#include <map>
#include <queue>
#include <vector>
#include <set>
#include <algorithm>
#include <math.h>
#include <cmath>
#include <stack>
#define mem0(a) memset(a,0,sizeof(a))
#define meminf(a) memset(a,0x3f,sizeof(a))
using namespace std;
typedef long long ll;
typedef long double ld;
typedef double db;
const int maxn=100005,inf=0x3f3f3f3f;  
const ll llinf=0x3f3f3f3f3f3f3f3f;   
const ld pi=acos(-1.0L);
int a[maxn];
int num;

struct Tree{
	int l,r,lc,rc,min;
};
Tree tree[maxn*4];

void build(int now,int l,int r) {
	tree[now].l=l;
	tree[now].r=r;
	if (l!=r) {
		num++;
		tree[now].lc=num;
		build(num,l,(l+r)/2);
		num++;
		tree[now].rc=num;
		build(num,(l+r)/2+1,r);
		tree[now].min=min(tree[tree[now].lc].min,tree[tree[now].rc].min);
	} else tree[now].min=a[l];
}

int findmin (int now,int l,int r,int val) {
//	cout << now << ' ' << tree[now].l << ' ' << tree[now].r << ' ' << tree[now].max << ' ' << tree[now].tag << endl;
	if (tree[now].l==tree[now].r) {
		return tree[now].l;
	} else {
		int f;
		if (l<=(tree[now].l+tree[now].r)/2&&tree[tree[now].lc].min<=val) {
			f=findmin(tree[now].lc,l,r,val);
			if (f!=-1) return f;
		}   
		if (r>(tree[now].l+tree[now].r)/2&&tree[tree[now].rc].min<=val) {
			f=findmin(tree[now].rc,l,r,val);
			if (f!=-1) return f;
		}
		return -1;
	}
//	cout << now << ' ' << tree[now].l << ' ' << tree[now].r << ' ' << tree[now].max << ' ' << tree[now].tag << endl;
}

int main() {
	int cas;
	scanf("%d",&cas);
	while (cas--) {
		int n,m,i,j,l,r;
		scanf("%d",&n);
		for (i=1;i<=n;i++) scanf("%d",&a[i]);
		num=1;
		build(1,1,n);
		scanf("%d",&m);
		for (i=1;i<=m;i++) {
			scanf("%d%d",&l,&r);
			int ans=a[l];
			l++;
			while (l<=r) {
				int p=findmin(1,l,r,ans);
				if (p==-1) break;
				ans%=a[p];
				l=p+1;
			}
			printf("%d\n",ans);
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值