Hdu 4405 Aeroplane chess DP求期望

Aeroplane chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4539    Accepted Submission(s): 2853


Problem Description
Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.
 

Input
There are multiple test cases. 
Each test case contains several lines.
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  
The input end with N=0, M=0. 
 

Output
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.
 

Sample Input
  
  
2 0 8 3 2 4 4 5 7 8 0 0
 

Sample Output
  
  
1.1667 2.3441
 

Source
 


飞行棋,从起点走到终点,每步有等可能的概率走1,2,3,4,5,6步。在格子间有一些快速通道,走过快速通道不算步数。每个格子最多是一个通道的起点。问走到终点的期望步数。


从终点向前推,一维DP,遇到通道则直接从通道连接的区域转移过来。判断一下即可。


#include <cstdio>
#include <iostream>
#include <string.h>
#include <string> 
#include <map>
#include <queue>
#include <deque>
#include <vector>
#include <set>
#include <algorithm>
#include <math.h>
#include <cmath>
#include <stack>
#include <iomanip>
#define mem0(a) memset(a,0,sizeof(a))
#define meminf(a) memset(a,0x3f,sizeof(a))
using namespace std;
typedef long long ll;
typedef long double ld;
typedef double db;
const int maxn=100005,inf=0x3f3f3f3f;  
const ll llinf=0x3f3f3f3f3f3f3f3f;   
const ld pi=acos(-1.0L);
vector<int> v[maxn],d[maxn];
db dp[maxn];

int main() {
	int n,m;
	scanf("%d%d",&n,&m);
	while (n||m) {
		int i,j,x,y;
		for (i=1;i<=m;i++) {
			scanf("%d%d",&x,&y);
			v[x].push_back(y);
			d[y].push_back(x);
		}
		dp[n]=0.0;
		for (i=n-1;i>=0;i--) {
			dp[i]=0.0;
			if (v[i].size()!=0) {
				dp[i]=dp[v[i][0]];
				continue;	
			}
			for (j=i+1;j<=min(n,i+6);j++) {
//				if (d[j].size()!=0) continue;
				dp[i]+=dp[j]*1.0/6.0;
			}
			dp[i]+=1.0;
		}
		printf("%.4lf\n",dp[0]);
		for (i=1;i<=n;i++) v[i].clear(),d[i].clear();
		scanf("%d%d",&n,&m);
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值