POJ2386 Lake Counting简单dfs

Lake Counting
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 36918 Accepted: 18352

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

这题可以说是dfs入门题了,题意是给你一个矩阵,W表示水坑,与它周围一圈的八个格子均算联通,要求总共有几个联通的水坑。

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <algorithm>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
typedef long long ll;
const int N = 1010;
int n,m;
using namespace std;
char Map[N][N];
void dfs(int x,int y)
{
    Map[x][y]='.';//这一步很关键,一定将对dfs到的点改为'.'
    for(int dx=-1; dx<=1; dx++)
        for(int dy=-1; dy<=1; dy++)//枚举所有的八种可能
        {
            int a=x+dx,b=y+dy;
            if(a>=0&&a<n&&b>=0&&b<m&&Map[a][b]=='W')
                dfs(a,b);
        }
}
int main()
{

    scanf("%d%d",&n,&m);
    getchar();
    int cnt=0;
    for(int i=0; i<n; i++)
    {
        for(int j=0; j<m; j++)
            scanf("%c",&Map[i][j]);
        getchar();
    }
    for(int i=0; i<n; i++)
        for(int j=0; j<m; j++)
            if(Map[i][j]=='W')//如果存在水坑,就对改点进行dfs
            {
                dfs(i,j);
                cnt++;
            }
    printf("%d\n",cnt);
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值