poj Lake Counting (dfs)

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.
这题就是用dfs写的,但是我学的不怎么好,就差那么一点居然没有看出来哪里错了,我也是醉了,所以还是多多练习吧

代码
#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string>
#include<string.h>
using namespace std;
int n,m,vis[120][120],dis[8][2]= {{1,0},{0,1},{-1,0},{0,-1},{-1,1},{1,1},{1,-1},{-1,-1}};
char str[120][120];
int flag;
bool judge(int lx,int ly)
{
    if(lx>=0&&lx<n&&ly>=0&&ly<m)
        return true;
    return false;
}
void dfs(int x,int y)
{
    for(int i=0; i<8; i++)
    {
        int lx=x+dis[i][0]; int ly=y+dis[i][1];
        if(str[lx][ly]=='W'&&!vis[lx][ly]&&judge(lx,ly))
        {
            vis[lx][ly]=1; dfs(lx,ly);
        }
    }
}
int main()
{
    int i,j;
    while(~scanf("%d%d",&n,&m))
    {
        for(i=0; i<n; i++)
        {
            getchar();
            for(j=0; j<m; j++)
            scanf("%c",&str[i][j]);
        }
        int sum=0;
        for(i=0; i<n; i++)
            for(j=0; j<m; j++)
                if(str[i][j]=='W'&&!vis[i][j])
                {
                    sum++; vis[i][j]=1; dfs(i,j);
                }
        printf("%d\n",sum);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值