POJ 3069 Saruman's Army

Saruman's Army
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12362 Accepted: 6226

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

简单贪心
我的代码:
//#include <bits/stdc++.h>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 1e4;
bool used[maxn];
int perm[maxn];
char s[maxn];
int n;
int main()
{
    int r,n;
    //freopen("/Users/vector/Desktop/input.txt","r",stdin);
    while(~scanf("%d%d",&r,&n))
    {
        int cnt = 0;
        if(r==-1&&n==-1)break;
        for(int i = 0; i < n; i++)
            scanf("%d",&perm[i]);
        sort(perm,perm+n);//排序
        for(int i = 0; i < n;)
        {
            int j = i;
            while(perm[i] + r >= perm[j+1] && j < n)
                j++;//向前探测
            i = j;
            while(perm[i] + r >= perm[j+1] && j < n)
                j++;//向后探测看能包括几个点
            cnt++;
            if(j >= n)break;
            i = j + 1;
        }
        printf("%d\n",cnt);
    }
    return 0;
}
《挑战》代码:
Source Code

Problem: 3069		User: 10152150116
Memory: 708K		Time: 16MS
Language: G++		Result: Accepted
Source Code
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <vector>
#include <cmath>
#include <cstring>
#include <string>
#define N 1e5+10
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
using namespace std;
int main(int argc, char** argv) {
	int r,n;
	while(~scanf("%d%d",&r,&n))
	{
		int loc[1010]={0};
		if(n==-1&&r==-1)break;
		for(int i=0;i<n;i++)
		scanf("%d",&loc[i]);
		sort(loc,loc+n);
		int index=0,cnt=0;
		while(index<n)
		{
			int s=loc[index];
			while(loc[index]-s<=r)
			index++;
			s=loc[index-1];
			while(s+r>=loc[index-1])
			index++;
			index--;
			cnt++;
		}
		printf("%d\n",cnt);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值