HDU1074 Doing Homework

Doing Homework

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11176    Accepted Submission(s): 5384


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject's homework). 

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.
 

Output
For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.
 

Sample Input
 
 
2 3 Computer 3 3 English 20 1 Math 3 2 3 Computer 3 3 English 6 3 Math 6 3
 

Sample Output
 
 
2 Computer Math English 3 Computer English Math
Hint
In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order.

 

状态压缩dp。

题意:有N门课,给出每门课的ddl和每门课所需要花的时间。

每门课超过ddl一天就会扣一分

不同的选择顺序就会有不同的扣分情况。

现在要你找到一种扣分最少的做作业的顺序。

考虑状态压缩。

所谓的状态压缩是指,相同的几门课分不同顺序完成,其消耗的时间是一样的。

但因为顺序的问题扣的分是不同的。

即可以把所有完成相同的作业看作是一个状态,对其dp值进行更新取最小的。

每次用位运算判断当前状态i这门课的作业有没有做

如果已经做了就continue

否则就看看添加进这门课会不会使得扣得分变少。

因为课程数量较小最大N只有15

所以可以考虑用二进制枚举从0到1<<15

二进制为0表示该课没有被选。

#include <bits/stdc++.h>
#include <iostream>
#include <stdlib.h>
#include <algorithm>
#include <queue>
#include <stdio.h>
#include <string.h>
#include <vector>
#include <climits>
#include <cmath>
#define max(a,b) (a>b)?a:b
#define min(a,b) (a<b)?a:b
using namespace std;
struct course
{
    string name;
    int d,c;
};
course a[20];
int n;
int dp[1 << 16];
int pre[1 << 16];
void output(int index)
{
    if(index == 0)
        return;

    int t;
    for(t = 0; t < n; t++)
        if (index & (1 << t))
            if(!(pre[index] & (1 << t)))//找到pre和index新增加的一位
            break;
    output(pre[index]);
    cout<<a[t].name<<endl;
    
}
int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    int T;
    cin>>T;
    while(T--)
    {
        cin>>n;
        for(int i = 0; i < n; i++)
            cin>>a[i].name>>a[i].d>>a[i].c;
        memset(dp,1,sizeof(dp));
        dp[0] = 0;
        for(int i = 0; i < 1<<n; i++)
            for(int j = 0; j < n; j++)
            {
                if(i & (1<<j)) continue;
                int s = 0;
                for(int k = 0; k < n; k++)
                    if((1<<k) & i) s += a[k].c;
                s += a[j].c;
                if(s > a[j].d) s -= a[j].d;
                else s = 0;
                if(dp[i | (1 << j)] > dp[i] + s)
                {
                    dp[i | (1 << j)] = dp[i] + s;
                    pre[i | (1 << j)] = i;//记录其前驱结点
                }
            }
        cout<<dp[(1 << n) - 1]<<endl;
        output((1 << n) - 1);//递归输出
    }
    return 0;
    
    
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值