PAT 1021 Deepest Root

1021 Deepest Root(25 分)

A graph which is connected and acyclic can be considered a tree. The hight of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​4​​) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components

题意:给定一棵树。问你以哪些结点作为根该树有最深的深度,升序输出这些结点。

如果有多个联通分量则输出error并输出联通分量个数

解法:两遍dfs。

第一次:从任何一个结点出发,到达最远的那个结点(可能是一个集合)一定是deepest root。再从该集合中任何一个点出发到达的最远的结点一定是deepest root。为了去重和升序,用set就可以了。

#include <bits/stdc++.h>
#define pii pair<int, int>
#define ll long long
#define eps 1e-5
using namespace std;
const int maxn = 2e4 + 10;
int n;
vector<int> tree[maxn];
set<int> ans;
bool vis[maxn];
int layer[maxn];
int depth;
void dfs(int id, int d)
{
    vis[id] = 1;
    layer[id] = d;
    depth = max(depth, d);
    for(auto idx: tree[id])
        if(!vis[idx])
            dfs(idx, d + 1);
}
int main()
{
    //    freopen("/Users/vector/Desktop/testdata.in", "r", stdin);
    ios::sync_with_stdio(false);
    cin.tie(0);
    cin >> n;
    for(int i = 1; i < n; i++)
    {
        int a, b;
        cin >> a >> b;
        tree[a].push_back(b);
        tree[b].push_back(a);
    }
    int time = 0;
    for(int i = 1; i <= n; i++)
        if(!vis[i])
        {
            dfs(i, 1);
            time++;
        }
    if(time > 1)
    {
        cout << "Error: " << time << " components" << endl;
        return 0;
    }
    for(int i = 1; i <= n; i++)
        if(layer[i] == depth)
            ans.insert(i);
    memset(vis, 0, sizeof(vis));
    depth = 0;
    dfs(*ans.begin(), 1);
    for(int i = 1; i <= n; i++)
        if(layer[i] == depth)
            ans.insert(i);
    for(auto idx: ans)
        cout << idx << endl;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值