困难的串uva129(dfs)

9 篇文章 0 订阅
7 篇文章 0 订阅
     Krypton Factor 

You have been employed by the organisers of a Super Krypton Factor Contest in which contestants have very high mental and physical abilities. In one section of the contest the contestants are tested on their ability to recall a sequence of characters which has been read to them by the Quiz Master. Many of the contestants are very good at recognising patterns. Therefore, in order to add some difficulty to this test, the organisers have decided that sequences containing certain types of repeated subsequences should not be used. However, they do not wish to remove all subsequences that are repeated, since in that case no single character could be repeated. This in itself would make the problem too easy for the contestants. Instead it is decided to eliminate all sequences containing an occurrence of two adjoining identical subsequences. Sequences containing such an occurrence will be called easy''. Other sequences will be calledhard”.

For example, the sequence ABACBCBAD is easy, since it contains an adjoining repetition of the subsequence CB. Other examples of easy sequences are:

BB
ABCDACABCAB
ABCDABCD

Some examples of hard sequences are:

D
DC
ABDAB
CBABCBA

Input and Output

In order to provide the Quiz Master with a potentially unlimited source of questions you are asked to write a program that will read input lines that contain integers n and L (in that order), where n > 0 and L is in the range tex2html_wrap_inline39 , and for each input line prints out the nth hard sequence (composed of letters drawn from the first L letters in the alphabet), in increasing alphabetical order (alphabetical ordering here corresponds to the normal ordering encountered in a dictionary), followed (on the next line) by the length of that sequence. The first sequence in this ordering is A. You may assume that for given n and L there do exist at least n hard sequences.

For example, with L = 3, the first 7 hard sequences are:

A
AB
ABA
ABAC
ABACA
ABACAB
ABACABA

As each sequence is potentially very long, split it into groups of four (4) characters separated by a space. If there are more than 16 such groups, please start a new line for the 17th group.

Therefore, if the integers 7 and 3 appear on an input line, the output lines produced should be

ABAC ABA
7

Input is terminated by a line containing two zeroes. Your program may assume a maximum sequence length of 80.

Sample Input

30 3
0 0

Sample Output

ABAC ABCA CBAB CABA CABC ACBA CABA
28

题意:如果一个字符串包含两个相邻的重复子串,则称它是“容易的串”,其他串称为“困难的串”。输入正整数n和 l,输出由前 l 个字符组成、字典序第n小的困难的串。

思路:这题和8皇后问题的解法差不多,只要判断当前串的后缀加入后,是否前后两段相同,如果不相同则可以继续添加,否则return ;

注意最后要每4个字符输出一个空格,每64个字符输出一个回车,最后输出字符串的长度。

代码为:

#include<iostream>
#include<cstdio>
#include<string.h>
using namespace std;
int n,l,a[100],cnt;
char st[26]={'A','B','C','D','E','F','G','H','I','J','K','L','M','N','O','P','Q','R','S','T','U','V','W','X','Y','Z'};
int dfs(int cur)
{
    if(cnt++==n)
    {
        for(int i=0;i<cur;i++)
        {
            if(i%4==0&&i!=64&&i!=0)
                cout<<" ";
            if(i==64)
                cout<<endl;
            printf("%c",'A'+a[i]);
        }
        cout<<endl;
        cout<<cur<<endl;
        return 1;
    }
    else for(int i=0;i<l;i++)
    {
        a[cur]=i;
        int ok=1;
        for(int j=1;j<=(cur+1)/2;j++)
        {
            int q=1;
            for(int k=0;k<j;k++)
            {
                if(a[cur-k]!=a[cur-j-k])
                {
                    q=0;
                    break;
                }
            }
            if(q)
            {
               ok=0;
               break;
            }
        }
        if(ok)
        {
            if(dfs(cur+1))
                return 1;
        }
    }
    return 0;
}
int main()
{
    while(cin>>n>>l&&(n+l))
    {
        cnt=0;
        memset(a,0,sizeof(a));
        dfs(0);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值