hdu5879 极限打表法

                Cure

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 484 Accepted Submission(s): 170

Problem Description
Given an integer n, we only want to know the sum of 1/k2 where k from 1 to n.

Input
There are multiple cases.
For each test case, there is a single line, containing a single positive integer n.
The input file is at most 1M.

Output
The required sum, rounded to the fifth digits after the decimal point.

Sample Input

1
2
4
8
15

Sample Output

1.00000
1.25000
1.42361
1.52742
1.58044

题目分析:n比较小的时候打表,把结果输出出来,当n比较大的时候值接近于π*π/6 , 所以都是固定的。n的最大极限大概在130000.
这个题目没有说n是多大,所以,n要用字符串存储,然后判断位数来处理。

代码为:

#include<iostream>
#include<cstdio>
#include<string.h>
using namespace std;
double a[200000];
int main()
{
    memset(a,0,sizeof(a));
    a[0]=0;
    int i;
    for(i=1;i<200000;i++)
    {
        a[i]=1.0/i/i+a[i-1];
    }
    string n;
    while(cin>>n)
    {
        if(n.length()>7)
        {
            cout<<"1.64493"<<endl;
            continue;
        }
        int sum=0;
        for(int i=0;i<n.length();i++)
        {
            sum=sum*10+(n[i]-'0');
        }
        if(sum>=200000)
        {
            cout<<"1.64493"<<endl;
        }
        else
        {
            printf("%.5lf\n",a[sum]);
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值