M-13

Description

As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list

1 4 3 2 9 7 18 22

your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.


Input

The input file will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.


Output

The output will consist of one line per input list, containing a count of the items that are double some other item.


Sample Input

1 4 3 2 9 7 18 22 0
2 4 8 10 0
7 5 11 13 1 3 0
-1


Sample Output

3
2
0

题意描述:

有一串数字,让你寻找列表中两倍关系的对数。

解题思路:

采用find函数寻找2倍的关系。

解题细节:

注意,set  可以使用 v.find()的形式,但是vector'不可以,会导致程序错误,vector可以使用find(v.begin(),v.end(),3)的形式,一定要注意。

代码:

#include <string>
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <set>
using namespace std;
int main()
{
    int i,j,k,sum=0;
    set<int>v;
    set<int>::iterator it;
    int n;
    while(cin>>n)
    {
        if(n==-1)
        break;
        if(n!=0)
        {
           v.insert(n);
        }
        if(n==0)
        {
            for(it=v.begin();it!=v.end();it++)
            {
                if(v.find(2*(*it))!=v.end())
                {
                    sum++;
                }

            }

        cout<<sum<<endl;
        v.clear();
        sum=0;
        }
    }
    return 0;
}

心得:

要仔细观察问题,掌握STL的应用,学会熟练运用它们。 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值