FatMouse's Speed(dp)

Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
 
Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.
 
Output

            Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that 

W[m[1]] < W[m[2]] < ... < W[m[n]]

and 

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.
 
Sample Input
6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900
 
Sample Output
4
4
5
9
7
 
 
Source
Zhejiang University Training Contest 2001
 
Recommend
Ignatius
 

此题目为经典的动态规划题目,让你寻找一组最长的随着体重增加而速度减小的,输出它们的编号!

代码;

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#include <iomanip>
#define MAXN 1000
#define maxn 15
#define mod 1000000007
#define INF 0x3f3f3f3f
#define exp 1e-6
#define pi acos(-1.0)
using namespace std;

struct Node    //建立一个结构体,存放数据
{
    int w,s;
    int index;
}mouse[MAXN+10];
bool cmp(Node a,Node b)   //自定义排序,先按体重有小到大在速度大到小
{
    if(a.w<b.w)  return 1;
    else if(a.w==b.w&&a.s>b.s)return 1;
    else return 0;
}
int dp[MAXN+10];   //dp[i]表示以第i个数据结尾的符合要求的子列长度/
int pre[MAXN+10];  //记录i对应的上一个数据
int res[MAXN+10];   //存放最终结果的下标
int main()
{
    int i=1,j;
    while(scanf("%d%d",&mouse[i].w,&mouse[i].s)!=EOF)
    {
        dp[i]=1;
        pre[i]=0;
        mouse[i].index=i;
        i++;
    }
    int n=i-1;
    sort(mouse+1,mouse+1+n,cmp);
    int maxlen=0; //最长序列长度
    int maxi;  //最长序列的最后一个下标
    dp[1]=1;
    for(i=1;i<=n;i++)
    {
        for(j=1;j<i;j++)
            if(mouse[i].w>mouse[j].w&&mouse[i].s<mouse[j].s&&dp[j]+1>dp[i])
            {
                 dp[i]=dp[j]+1;
                 pre[i]=j;
                 if(dp[i]>maxlen)
                 {
                       maxi=i;
                       maxlen=dp[i];  //最大
                 }
            }
    }
    int t=maxi;
    i=0;
    while(t!=0)
    {
        res[i++]=t;
        t=pre[t];   //直到前一个为0即不存在前一个了
    }
    printf("%d\n",i);
    while(i>0)
    {
        i--;
        printf("%d\n",mouse[res[i]].index);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值