Can you find it?(二分)

Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 
Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 
Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 
Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10
 
Sample Output
Case 1:
NO
YES
NO
 
Author
wangye
 
Source
HDU 2007-11 Programming Contest
 
Recommend
威士忌

首先这个题目一拿过来毫无思路,但是仔细分析发现可以合并前两项的和,然后用s减去最后一项的和,然后在寻找!

给你三组A、B、C的值和S值,问是否能找到Ai、Bj、Ck,使得Ai+Bj+Ck = S。二分,先将a数组和b数组,再相加成一个数组ab[500*500]。这样就相当于ab[i] + c[j] = s。再变形一下, ab[i] = s - c[j].只要在ab数组中用二分查找是否存在s-c[j]就可以了。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#include <iomanip>
#define maxn 15
#define mod 1000000007
#define INF 0x3f3f3f3f
#define exp 1e-6
#define pi acos(-1.0)
using namespace std;
int a[505],b[505],c[505];
int ab[250001],s[505];
bool find(int a,int b,int c)
{
	if(b>c)
	return false;    //结束 
	int mid=(c+b)/2;
	if(ab[mid]==a)
	return true;
	else if(ab[mid]>a)
	find(a,b,mid-1);
	else
	find(a,mid+1,c);
}
int main()
{
	int l,n,m,i,j,k,s,sum;
	int d=0;
	while(cin>>l>>n>>m)
	{
		d++;
	for( i = 0; i < l; i++)  
        cin >> a[i];  
           
    for( i = 0; i < n; i++)  
         cin >> b[i];  
           
    for( i = 0; i < m; i++)  
         cin >> c[i];  
    for(k=0, i=0;i<l; i++)  
    {  
        for( j=0; j<n; j++)  
        {  
            ab[k++] = a[i] + b[j];  
        }  
    } 
	sort(ab,ab+k);
	cin>>s;
	cout<<"Case "<<d<<":"<<endl;
	for(i=0;i<s;i++)
	{
		cin>>sum;
		for(j=0;j<m;j++)
		{
			if(find(sum-c[j],0,k-1))
			break;
			
		}
				
	if(j==m)
		cout<<"NO"<<endl;
	else 
	cout<<"YES" <<endl; 
}

} 
return 0;

}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值