Hopscotch(dfs)

Hopscotch
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4453 Accepted: 2973

Description

The cows play the child's game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes.

They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited).

With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201).

Determine the count of the number of distinct integers that can be created in this manner.

Input

* Lines 1..5: The grid, five integers per line

Output

* Line 1: The number of distinct integers that can be constructed

Sample Input

1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1

Sample Output

15

Hint

OUTPUT DETAILS:
111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.

Source


题意:

从任意一个点出发,任意走六步,共有多少种不同的数字组合方案。

思路:

搜索,遍历每一个点为起点时的情况,然后记录下来总的方案数,找不同的个数可以用个sort函数,使问题简单化。

代码:

#include <iostream>
#include <cstring>
#include <string>
#include <stdio.h>
#include <algorithm>
using namespace std;
int a[100010],mp[6][6],sum,ans;
int dir[4][2]={{-1,0},{1,0},{0,-1},{0,1}};
void dfs(int x,int y,int m,int n)   //xy代表坐标,m代表目前所形成的数,n代表长度
{
    int i;
    if(n==6)
    {
        a[ans++]=m;   //找到一种情况。
        return;
    }
    m=m*10+mp[x][y];
    for(i=0;i<4;i++)
    {
        int xx=x+dir[i][0];
        int yy=y+dir[i][1];
        if(xx>=0&&xx<5&&yy>=0&&yy<5)
        {
            dfs(xx,yy,m,n+1);
        }
    }
}
int main()
{
    int i,j;
    ans=0;
    for(i=0;i<5;i++)
        for(j=0;j<5;j++)
    {
        scanf("%d",&mp[i][j]);
    }
    for(i=0;i<5;i++)
        for(j=0;j<5;j++)
    {
        dfs(i,j,0,0);
    }
    sort(a,a+ans);
    sum=1;
    for(i=0;i<ans-1;i++)
    {
        if(a[i]!=a[i+1])sum++;
    }
    printf("%d\n",sum);
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值